dev-kit board, no /dev/video0 for onboard camera

Gents,
I have added this patch to the kernel source (dts-files)
https://devtalk.nvidia.com/default/topic/920739/jetson-tx1/l4t-r23-2-for-jetson-tx1-released/post/4824232/#4824232
Compiled, the dtb file added to the Jetson, and reboot.
After that, I didn’t find a /dev/video0 device for the camera…

Any hints, what I’m doing wrong ?

Thanks
Peter

I have not worked with video, but /dev/video0 is the side-effect of a running kernel feature. If the feature is in the form of a module, then missing the file could mean the module wasn’t loaded. Since you just made a change, perhaps the change did not make it in. In the case of dts files, the install is a bit less obvious, and so even if the module made it in perhaps the dtb did not.

If you look in “/boot/extlinux/extlinux.conf”, the final file name u-boot looks for is from the “FDT” key/value pair. This provides the name and location of the file the dts edit would have had to have generated during kernel build somewhere in the "arch/arm64/boot/dts/’ directory. If modules themselves were changed then the usual details about making sure CONFIG_LOCALVERSION was correct also kicks in.

Thanks,
solved with the correct kernel-modules…
Thanks

Which modules did you use? More than mentioned in R23.2 NVIDIA Tegra Linux Driver Package Development Guide?

$ sudo rmmod nvhost-vi
$ sudo modprobe ov5693_v4l2
$ sudo modprobe tegra_camera

Thanks.