/dev/nvidia* missing /CentOS 7.9 | GM204GL [Tesla M60] | CUDA 8

I am facing a hard time with Cuda 8 on centOS 7.9 having NVIDIA Corporation GM204GL [Tesla M60] card. I followed steps in the official documentation for the installation with rpm/run and patch from the archive as well, and the installation is done without any error, but when executing nvidia-smi, it’s throwing the below error. I have checked almost all the CentOS related post over the internet but unable to fix.
NVIDIA-SMI has failed because it couldn't communicate with the NVIDIA driver. Make sure that the latest NVIDIA driver is installed and running.

I tried to check for nvidia inside /dev/, there was no files so I used script but it was throwing error modprobe: FATAL: Module nvidia not found.*

/sbin/modprobe nvidia
if [ "$?" -eq 0 ]; then
 # Count the number of NVIDIA controllers found.
 NVDEVS=`lspci | grep -i NVIDIA`
 N3D=`echo "$NVDEVS" | grep "3D controller" | wc -l`
 NVGA=`echo "$NVDEVS" | grep "VGA compatible controller" | wc -l`
 N=`expr $N3D + $NVGA - 1`
 for i in `seq 0 $N`; do
 mknod -m 666 /dev/nvidia$i c 195 $i
 mknod -m 666 /dev/nvidiactl c 195 255
 exit 1
/sbin/modprobe nvidia-uvm
if [ "$?" -eq 0 ]; then
 # Find out the major device number used by the nvidia-uvm driver
 D=`grep nvidia-uvm /proc/devices | awk '{print $1}'`
 mknod -m 666 /dev/nvidia-uvm c $D 0
  exit 1

When I tried with rpm, I am getting below while installation somewhere in between

'make' -j8 NV_EXCLUDE_BUILD_MODULES='' KERNEL_UNAME=3.10.0-1160.31.1.el7.x86_64 modules....(bad exit status: 2)

Error! Bad return status for module build on kernel: 3.10.0-1160.31.1.el7.x86_64 (x86_64)

Consult /var/lib/dkms/nvidia/375.26/build/make.log for more information.

warning: %post(nvidia-kmod-1:375.26-2.el7.x86_64) scriptlet failed, exit status 10

Non-fatal POSTIN scriptlet failure in rpm package 1:nvidia-kmod-375.26-2.el7.x86_64

Also below is the kernel version I am using

$rpm -qa | grep kernel

The kernel version in bold seems of diff version, Is it a problem?

Need help to fix this. Also, I have now doubt if M60 card is supported by cuda 8?
Support Matrix :: NVIDIA Deep Learning cuDNN Documentation