/dev/ttyUSB* not found

i was running a rgbd-obstacle-avoidance program in TX1,i should use the uart at the same time,when i run my program like this:

./bin/Orbbec_Obstacle_Avoidance

then appear error:


<ul><li>Warning: USB events thread - failed to set priority.
 This might cause loss of data...The grabber started!CObstacleDetection::verifyPlaneModel,
 theta = 2.90401terminate called after throwing an instance of 'boost::exception_detail::clone_impl<boost::exception_detail::
error_info_injector<boost::system::system_error> >'  what():  
open: No such file or directoryAborted</li>
</ul>

then i run the command :

lsusb

then appear:


<ul><li>Bus 002 Device 003: ID 05e3:0612 Genesys Logic, Inc. 
Bus 002 Device 002: ID 0955:09ff NVidia Corp. 
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 013: ID 1908:2310 GEMBIRD 
Bus 001 Device 012: ID 04d9:a096 Holtek Semiconductor, Inc. 
Bus 001 Device 011: ID 093a:2510 Pixart Imaging, Inc. Optical Mouse
Bus 001 Device 010: ID 0424:2514 Standard Microsystems Corp. USB 2.0 Hub
Bus 001 Device 016: ID 10c4:ea60 Cygnal Integrated Products, Inc. CP210x UART Bridge / myAVR mySmartUSB light
Bus 001 Device 003: ID 05e3:0610 Genesys Logic, Inc. 4-port hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub</li>
</ul>

it means that i can find the UART Bridge,but when i run the command

ls /dev/ttyUSB*

then appear:

ls: cannot access '/dev/ttyUSB*': No such file or directory

but i try it in my pc(not TX1),i run the ls ls /dev/ttyUSB*,it can find the ttyUSB0.

how can i solve the problem?very thankful!

Using this thread for forum response, the TK1 duplicate thread should be ignored.

It sounds like the device uses a common USB chip for communications, which wouldn’t need anything special for support. Basically you have two steps involved in getting the “/dev/ttyUSB*” file. First, USB asks the device what it is…enumeration…and lsusb would show if the query worked. It also sounds like lsusb shows the device…verify if I am correct that the device is the one listed in this lsusb line:

Bus 001 Device 016: ID 10c4:ea60 Cygnal Integrated Products, Inc. CP210x UART Bridge / myAVR mySmartUSB light

Assuming this is the correct device (and the only device related to this product), then this will give detailed information on the USB side which you can post here:

sudo lsusb -vvv -d '10c4:ea60'

All of that is simply to tell the kernel about a device with some capability, and to provide USB as a way of talking to that capability. The driver required for generating the “/dev/ttyUSB*” is separate. Upon plugging in the USB cable (or powering up) you will essentially get a message generated by the USB hotplug layer to say that some device has been found, and that a driver can take ownership of the device. That driver would be responsible for generating the “/dev/ttyUSB*” entry. Either no driver took ownership, or the file generated is named wrong (the udev system can rename devices based on rules). Odds are that since ttyUSB# is a sort of standard serial UART naming that udev was not required for renaming and that the problem would be that no driver took ownership.

If you leave the device unplugged, boot up the Jetson, and check the end of “dmesg” to see what is there already, followed by plugging in the USB connector and checking for new output in dmesg (e.g., “dmesg | tail -n 50”), what is shown by plugging in the device? Do this both for the computer where it works, and for the Jetson…I’m hoping that on the working computer the required driver is mentioned, and that on the Jetson it may verify no driver claimed the device.