/dev/video0 not populated in 28.1 with yuv camera

I have a v4l2src yuv camera that I’m basing off the imx185 driver. Basically I’ve taken the imx185 driver, changed the V4L2 format, and also stubbed out the i2c regmap calls (my camera has no i2c).

The driver probe finishes fine but I see no /dev/video0.

One thing that I don’t get is if in my device tree I use vi@15700000 the kernel crashes. If I do it the old way and just use “vi” it initializes fine. Is that a clue?

Could you check the “sensor programing guide” the Device Registration section to use 'Using Main Platform Device Tree File"

ShaneCCC,
So, I think my crashing was due to a format error. This post helped.

https://devtalk.nvidia.com/default/topic/1004084/jetson-tx1/tx1-camera-driver-format-issue/

Now that I can try out yavta and gstreamer pipes I’ve run into a problem I saw with 27.1

[   49.052563] tegra-vi4 15700000.vi: PXL_SOF syncpt timeout! err = -11
[   50.056508] tegra-vi4 15700000.vi: ATOMP_FE syncpt timeout!

[ 3169.773620] nvcsi 150c0000.nvcsi: csi4_stream_check_status (0) ERROR_STATUS2VI_VC0 =
 0x00000004
[ 3169.782480] nvcsi 150c0000.nvcsi: csi4_stream_check_status (0) INTR_STATUS 0x0000000
4
[ 3169.790805] nvcsi 150c0000.nvcsi: csi4_stream_check_status (0) ERR_INTR_STATUS 0x000
00004

I know my hardware is fine as it works with the TX1 and old 3.1 driver. My device tree is very similar to the imx185, which I’ve tested and works.

Do you have any thoughts on what causes these errors?

Try to modify ths_settle it’s a 6 bit value range is 0 - 0x3F

drivers/media/platform/tegra/camera/csi/csi4_registers.h

#define T18X_BYPASS_LP_SEQ			(0x1 << 7)
#define DEFAULT_THS_SETTLE					(0x14 << 0)

ShaneCCC,
Sorry if this is obvious, but any guidance on which direction I should change it? Lower/higher? Is this a settling time?

I tried changing to 0x5 and 0x3F but still see these

tegra-vi4 15700000.vi: PXL_SOF syncpt timeout! err = -11

clutch12, did you have any success? I have the same problems here.
Some addition: AFAIK, from the Parker TRM 28.6.62. INTR_STATUS 0x00000004 means intr_stat_pd_crc_err_vc0 .

i wish i remember this better. i ended up changing some of the csi stuff in the device tree I think to make this work but its been months so my memory is fuzzy.

I don’t know if it is directly related, but after I changed my ‘badge’ in the tegra-camera-platform part of my device tree file, I didn’t get the ‘PXL_SOF syncpt timeout! err = -11’ error

Edit: Turns out it isn’t. I’m still getting the error

Have a check below link to enable the notify trace for TX2.

https://elinux.org/Jetson_TX2/28.1_Camera_BringUp

Hello @ShaneCCCC. Could you help me debug the problem in this post: https://devtalk.nvidia.com/default/topic/1047143/jetson-tx2/blurred-output-video-and-mipi-cal-timeout-error-with-imx219-/