Device combo Empty

Tegra Android Developer Pack 2.0r2

In the device combo, just after VisualStudio 2010 has loaded, there is a “Waiting for ADB…” message
after a while the text changes in ‘’

Shouldn’t I see some virtual device?

what happens when you type in ‘adb devices’ on the command line?

* daemon not running. starting it now on port 5037 *
* daemon started successfully *
List of devices attached

and then it returns back to the prompt

also, i’ve tried with a real device attached but i do get the same empty list
‘usb driver’ did not installed correctly so this might be the culprit

Looking at the command line, it seems your virtual device hasn’t been started. Are you sure it is running?
And as I mentioned in the ogre forums (hi!) I humbly suggest you use a real device as they are a lot faster. Setting up the USB driver is necessary. If you tell me what device you have, I might offer some help (I wasted a lot of time getting my Samsung devices to run)

Ciao Emerix seems we meet in every possible forums :)

Yes, I’ve tried a real device too (GT-P3100), but I still get an empty list.
I’m reading some docs, ‘adb devices’ should really list at least some emulator so it must be some android sdk installation issue

Possibly, best check the SDK folder from the NTVSE installation and try to install the drivers from there.
Also make sure your device is in debug mode and that you have the correct drivers. I had to install the Samsung specific ones to get the Laptop to see my GT-P1000.

After making sure your Tab is in USB Debugging mode, plug it in and check your windows device manager to see whether the drivers were installed correctly.
To get my P1000 installed properly, I had to install the Samsung USB drivers. I took them from the XDA developers page (http://forum.xda-developers.com/showthread.php?t=2038555 - warning! external link. go guarantees. use at own risk and all that)
I downloaded the .RAR archive and unpacked it in a folder of my choice, then back in the device manager, I picked “update drivers” and told it to look in that unpacked RAR folder. I did that for every device associated with my GT-P1000.
It recognized the drivers from that package and installed them. Afterwards the device was detected by the ADB (and thus the adb devices command). That means the NTVSE plugin was able to find the device, too (reboot might be necessary)