deviceQuery fails: access violation

Hi,

unfortunately I was not able to find any solution on the board for my current problem: it seems that any call to CUDA fails, even the deviceQuery example won’t work. When tracing the problem there seems to be an access violation in nvcuda.dll.

Exception thrown at 0x000007FEDA615715 (nvcuda.dll) in deviceQuery.exe: 0xC0000005: Access violation reading location 0x0000000000000010.

StackTrace:
‘deviceQuery.exe’ (Win32): Loaded ‘C:\ProgramData\NVIDIA Corporation\CUDA Samples\v10.0\bin\win64\Debug\deviceQuery.exe’. Symbols loaded.
‘deviceQuery.exe’ (Win32): Loaded ‘C:\Windows\System32\ntdll.dll’. Cannot find or open the PDB file.
‘deviceQuery.exe’ (Win32): Loaded ‘C:\Windows\System32\kernel32.dll’. Cannot find or open the PDB file.
‘deviceQuery.exe’ (Win32): Loaded ‘C:\Windows\System32\KernelBase.dll’. Cannot find or open the PDB file.
‘deviceQuery.exe’ (Win32): Loaded ‘C:\Windows\System32\shell32.dll’. Cannot find or open the PDB file.
‘deviceQuery.exe’ (Win32): Loaded ‘C:\Windows\System32\msvcrt.dll’. Cannot find or open the PDB file.
‘deviceQuery.exe’ (Win32): Loaded ‘C:\Windows\System32\shlwapi.dll’. Cannot find or open the PDB file.
‘deviceQuery.exe’ (Win32): Loaded ‘C:\Windows\System32\gdi32.dll’. Cannot find or open the PDB file.
‘deviceQuery.exe’ (Win32): Loaded ‘C:\Windows\System32\user32.dll’. Cannot find or open the PDB file.
‘deviceQuery.exe’ (Win32): Loaded ‘C:\Windows\System32\lpk.dll’. Cannot find or open the PDB file.
‘deviceQuery.exe’ (Win32): Loaded ‘C:\Windows\System32\usp10.dll’. Cannot find or open the PDB file.
‘deviceQuery.exe’ (Win32): Loaded ‘C:\Windows\System32\imm32.dll’. Cannot find or open the PDB file.
‘deviceQuery.exe’ (Win32): Loaded ‘C:\Windows\System32\msctf.dll’. Cannot find or open the PDB file.
‘deviceQuery.exe’ (Win32): Loaded ‘C:\Windows\System32\api-ms-win-core-synch-l1-2-0.dll’. Cannot find or open the PDB file.
‘deviceQuery.exe’ (Win32): Loaded ‘C:\Windows\System32\advapi32.dll’. Cannot find or open the PDB file.
‘deviceQuery.exe’ (Win32): Loaded ‘C:\Windows\System32\sechost.dll’. Cannot find or open the PDB file.
‘deviceQuery.exe’ (Win32): Loaded ‘C:\Windows\System32\rpcrt4.dll’. Cannot find or open the PDB file.
‘deviceQuery.exe’ (Win32): Loaded ‘C:\Windows\System32\nvcuda.dll’. Cannot find or open the PDB file.
‘deviceQuery.exe’ (Win32): Loaded ‘C:\Windows\System32\version.dll’. Cannot find or open the PDB file.
‘deviceQuery.exe’ (Win32): Loaded ‘C:\Windows\System32\setupapi.dll’. Cannot find or open the PDB file.
‘deviceQuery.exe’ (Win32): Loaded ‘C:\Windows\System32\cfgmgr32.dll’. Cannot find or open the PDB file.
‘deviceQuery.exe’ (Win32): Loaded ‘C:\Windows\System32\oleaut32.dll’. Cannot find or open the PDB file.
‘deviceQuery.exe’ (Win32): Loaded ‘C:\Windows\System32\ole32.dll’. Cannot find or open the PDB file.
‘deviceQuery.exe’ (Win32): Loaded ‘C:\Windows\System32\devobj.dll’. Cannot find or open the PDB file.
‘deviceQuery.exe’ (Win32): Loaded ‘C:\Windows\System32\nvfatbinaryLoader.dll’. Cannot find or open the PDB file.
‘deviceQuery.exe’ (Win32): Loaded ‘C:\Windows\System32\ws2_32.dll’. Cannot find or open the PDB file.
‘deviceQuery.exe’ (Win32): Loaded ‘C:\Windows\System32\nsi.dll’. Cannot find or open the PDB file.
‘deviceQuery.exe’ (Win32): Loaded ‘C:\Windows\System32\dwmapi.dll’. Cannot find or open the PDB file.
‘deviceQuery.exe’ (Win32): Unloaded ‘C:\Windows\System32\dwmapi.dll’
‘deviceQuery.exe’ (Win32): Loaded ‘C:\Windows\System32\nvapi64.dll’. Cannot find or open the PDB file.
‘deviceQuery.exe’ (Win32): Loaded ‘C:\Windows\System32\dxgi.dll’. Cannot find or open the PDB file.
‘deviceQuery.exe’ (Win32): Loaded ‘C:\Windows\System32\dwmapi.dll’. Cannot find or open the PDB file.
‘deviceQuery.exe’ (Win32): Loaded ‘C:\Windows\System32\uxtheme.dll’. Cannot find or open the PDB file.
Exception thrown at 0x000007FEDA615715 (nvcuda.dll) in deviceQuery.exe: 0xC0000005: Access violation reading location 0x0000000000000010.

My setup is as follows: Windows 7 64 Bit, Geforce GTX 1050 Ti. driver version 417.71, CUDA 10. The driver seems to work fine, see nvidia-smi output below. I also tried several times a clean driver and CUDA installation, also with older versions but basically the same error remains.

Any ideas how to solve the problem?

Thank you for your help!
Torsten

±----------------------------------------------------------------------------+
| NVIDIA-SMI 417.71 Driver Version: 417.71 CUDA Version: 10.0 |
|-------------------------------±---------------------±---------------------+
| GPU Name TCC/WDDM | Bus-Id Disp.A | Volatile Uncorr. ECC |
| Fan Temp Perf Pwr:Usage/Cap| Memory-Usage | GPU-Util Compute M. |
|===============================+======================+======================|
| 0 GeForce GTX 105… WDDM | 00000000:01:00.0 On | N/A |
| 30% 30C P0 N/A / 75W | 363MiB / 4096MiB | 0% Default |
±------------------------------±---------------------±---------------------+

±----------------------------------------------------------------------------+
| Processes: GPU Memory |
| GPU PID Type Process name Usage |
|=============================================================================|
| 0 4512 C+G …iles\MATLAB\R2018a\bin\win64\MATLAB.exe N/A |
| 0 4788 C+G …DIA GeForce Experience\NVIDIA Share.exe N/A |
| 0 6236 C+G …)\Microsoft Office\Office15\OUTLOOK.EXE N/A |
| 0 9248 C+G …DIA GeForce Experience\NVIDIA Share.exe N/A |
| 0 10944 C+G C:\Windows\system32\Dwm.exe N/A |
±----------------------------------------------------------------------------+