deviceQuery Fails When Adding K20Xm

My Fedora 16 X86_64 system has a Tesla C2050. I added a K20Xm and I cannot use the hardware. The deviceQuery program prints

cudaGetDeviceCount returned 10
-> invalid device ordinal

I ran the program with strace and found the open of /dev/nvidia0 returns an EIO error. The file /proc/driver/nvidia/gpus/0/information displays

Model:          Tesla K20Xm
IRQ:            16
GPU UUID:      GPU-????????-????-????-????-????????????
Video BIOS:      ??.??.??.??.??
Bus Type:      PCIe
DMA Size:      40 bits
DMA Mask:      0xffffffffff
Bus Location:      0000:01.00.0

Any suggestions? Is the card failed?
By the way, /proc/driver/nvidia/gpus/1/information displays

Model:          Tesla C2050
IRQ:            16
GPU UUID:      GPU-bf36b99f-0ea0-fdb5-6b30-2193ba5b92cb
Video BIOS:      70.00.2b.00.02
Bus Type:      PCIe
DMA Size:      39 bits
DMA Mask:      0x7fffffffff
Bus Location:      0000:06.00.0

Does the card have both PCI-E power connectors connected? Have you tried switching slots between cards?

Yes, both power connectors are connected. I have tried switching slots. I have tried with both FC16 & FC18. Latest test with FC18 (clean installation) without NVIDIA RPMs. I use the .run install method with driver 319.60 and cuda 5.5.22. Same error messages when running the deviceQuery program and catting /proc/drivers files as noted above.

I am beginning to think I have a hardware problem.

Does it work in another O/S? i.e. Windows? Or on another machine? That would narrow down a hardware problem to the card if it doesn’t work that way.

I do not have ready access to either another OS or another machine. The machine is a Dell XPS 710.

I tried all four permutations of power cables and slots. According to https://developer.nvidia.com/cuda-downloads FC18 is a supported OS. Is anything else required other than a clean install and the CUDA tools and NVIDIA driver? Does NVIDIA have a diagnostic program? The card is visible to the Kernel (as evidenced by DMESG output and the lscpi utility).

I believe K20Xm doesn’t have a video output, so trying it out as your main video card is out. There’s nothing else required, really. You’d have to inquire with the reseller you purchased the card from to escalate to NVIDIA support. It could be the card or it could be the specific hardware combination that doesn’t play nicely… no real way to tell unless you perform the tests on another PC / another OS.