Devtool extract fails with tegra-bootfiles

devtool extract tegra-bootfiles /tmp/boot/
NOTE: Starting bitbake server...
NOTE: Reconnecting to bitbake server...
NOTE: Retrying server connection (#1)...

Loading cache: 100% |##################################################################| Time: 0:00:00
Loaded 4380 entries from dependency cache.

Summary: There was 1 WARNING message.
INFO: The tegra-bootfiles recipe has do_patch disabled. Running only do_configure task dependencies
Traceback (most recent call last):
  File "/data/workspace/kirkstone/poky/scripts/devtool", line 338, in <module>
    ret = main()
  File "/data/workspace/kirkstone/poky/scripts/devtool", line 325, in main
    ret = args.func(args, config, basepath, workspace)
  File "/data/workspace/kirkstone/poky/scripts/lib/devtool/standard.py", line 422, in extract
    initial_rev, _ = _extract_source(srctree, args.keep_temp, args.branch, False, config, basepath, workspace, args.fixed_setup, rd, tinfoil, no_overrides=args.no_overrides)
  File "/data/workspace/kirkstone/poky/scripts/lib/devtool/standard.py", line 601, in _extract_source
    pn = pn.replace('${COMPILERDEP}', d.getVar('COMPILERDEP'))
TypeError: replace() argument 2 must be str, not None

Any suggestion?

Hi
Please share where you see the steps. Seems like we don’t have the steps in our developer guide. Would like to get more information about the use-case.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.