Difference between docker containers


I’ve downloaded the following docker containers:

  1. nvcr.io/nvidia/l4t-ml (tag: r34.1.1-py3)
  2. nvcr.io/nvidia/l4t-tensorflow (tag: r34.1.1-tf2.8-py3)
  3. nvcr.io/nvidia/l4t-tensorflow (tag: r32.6.1-tf2.5-py3)
    and run the docker with each one applying the following procedure:
  • activating python3
  • import tensorflow

When run it with the ml container I got the following notifications:

I tensorflow/stream_executor/platform/default/dso_loader.cc:49] Successfully opened dynamic library libcudart.so.11.0
WARNING:tensorflow:Deprecation warnings have been disabled. Set TF_ENABLE_DEPRECATION_WARNINGS=1 to re-enable them.

When run it with the tensorflow 2.8 container it got completed with no notification.

When run it with the tensorflow 2.5 container the following error/warning was noted:

W tensorflow/stream_executor/platform/default/dso_loader.cc:64] Could not load dynamic library ‘libcudart.so.10.2’; dlerror: libcudart.so.10.2: cannot open shared object file: No such file or directory; LD_LIBRARY_PATH: /usr/local/cuda/lib64:/usr/local/cuda-10.2/targets/aarch64-linux/lib:
2022-06-21 06:04:11.875329: I tensorflow/stream_executor/cuda/cudart_stub.cc:29] Ignore above cudart dlerror if you do not have a GPU set up on your machine.

Could someone elaborate on the differences?


Please check below for the details:

  • l4t-tensorflow:r32.6.1-tf2.5-py3
    This container is for the r32.6.1 (JetPack4.6.x) user.
    Since Orin requires the r34.1.x branch, it cannot be used on the Orin.

  • l4t-tensorflow:r34.1.1-tf2.8-py3
    This container has TensorFlow v2.8 pre-installed.

  • l4t-ml:r34.1.1-py3
    This container includes several popular frameworks, ex. TensorFlow, PyTorch, …
    It usually includes TensorFlow v1.15.x.


Hi, thanks for the prompt reply.

Is there any significance between options nvcr.io/nvidia/l4t-ml and nvcr.io/nvidia/l4t-tensorflow: r34.1.1-tf2.8-py3, like the fact that the first option prints the warning detailed above?


l4t-ml:r34.1.1-py3 uses TF v1.15 but l4t-tensorflow:r34.1.1-tf2.8-py3 installs TF v2.8.
The warning you observed is triggered by the TensorFlow v1.15 package.

The API between TF v1 and TF v2 is quite different.
Please choose one based on your use case.


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.