Different result with same code and video on Xavier NX

Hello!
I’m developing a video analysis project with deepstream on Jetson Xavier NX.
Now I have finished code on my PC with 3090 and it runs perfect. When I run the code and video on NX, everytime I run the code on the same NX device ,the result is different! But with 3090,the result is all the same.
the pipeline like this:


pgie is used to detect object and send every object to sgie to segmentation.

PGIE config:

SGIE config:

compare two result

So , Why is the result different and is there some special config I should set with Jetson?

Hi @MADBOB , Could you attach your stream, code, model and config file?
Also please provide complete information as applicable to your setup.

• Hardware Platform (Jetson / GPU)
• DeepStream Version
• JetPack Version (valid for Jetson only)
• TensorRT Version
• NVIDIA GPU Driver Version (valid for GPU only)
• Issue Type( questions, new requirements, bugs)
• How to reproduce the issue ? (This is for bugs. Including which sample app is using, the configuration files content, the command line used and other details for reproducing)
• Requirement details( This is for new requirement. Including the module name-for which plugin or for which sample application, the function description)

  1. Hardware Platform: Jetson Xavier NX
  2. DeepStream Version: 6.1 and 6.0.1
  3. JetPakc Version: 5.0.2 and 4.6.2

On my PC with 3090 GPU, 510.47 Driver , DS6.1,TRT8.4 ,the code work well , all result is the same.
When I run code in Jetson , I run the same video with the same code twice, the result is different

Following ZipFile is my demo code, I delete some useless info. the main pipeline like this . Is there any special config I didn’t set for Jetson Platform?
ds_problem.zip (5.2 KB)

There is no update from you for a period, assuming this is not an issue anymore.
Hence we are closing this topic. If need further support, please open a new one.
Thanks

There is no special config paras about this. Cause the code cannot be run well in my env. Could you run our demo code deepstream-nvdsanalytics and check if the result is the same?

Hello:
I know the reason why I run twice and the result is different. On jetson,default nvinfer property scaling-compute-hw is using VIC ,When I change it to gpu, all results are same.

@MADBOB , are they fixed frames each time when there are different results?

No. I run several times, save result to file and compare them.



It looks like the different result is around some fixed frames.
Beacuse my sgie is a unet model and i need to compute the area

From the log attached, the org_box is same. But the area is not.
What does the paras, (area, minrect, dis, weight) exactly mean here?

Hi @MADBOB , We cannot repoduce it in our env with our model. So could you please attach your model? Also please answer the above questions if you have time. Thanks

What does the paras, (area, minrect, dis, weight) exactly mean here?

Hello, I may spend time to reproduce it after I finsh this project . Because of some company security reason , I could not attch my model , Maybe I will retrain a model and reproduce it later . Now I’m using GPU for scaling-compute-hw and it works fine .

OK,you can attach your retrained model and demo code when you have time. If we can run your project and reproduce in our environment, we can analyze and resolve it faster. Thanks