Difficulties install paraview connector

Hi,I’m trying to install paraview connector with ubuntu 20.04. I could not install directly from Omniverse launcher, it keeps give me the following error even though I have exported the PVOV_INSTALL_PATH.

Error occurred during installation of Kitware ParaView: Command failed: “/home/juntao/.local/share/ov/pkg/paraview-connector-100.0.0/ParaViewOmniSetup.sh” -i
Error: PVOV_INSTALL_PATH not set! Aborting install…

So I tried to run ParaViewOmniSetup.sh from terminal, and it installs and shows

Installing to: /usr/local/
Install successful

But if I go to the launcher, the installation is not reflected. And paraview also crashes after the “successful” installation with the following error.

free(): invalid pointer

Loguru caught a signal: SIGABRT
Stack trace:
20 0x564ab60c01fe paraview(+0x91fe) [0x564ab60c01fe]
19 0x7f0f17e310b3 __libc_start_main + 243
18 0x564ab60bfec5 paraview(+0x8ec5) [0x564ab60bfec5]
17 0x564ab60c52e6 paraview(+0xe2e6) [0x564ab60c52e6]
16 0x7f0f153a00a3 vtkPVPluginTracker::LoadPluginConfigurationXMLs(char const*) + 1475
15 0x7f0f1539f7d3 vtkPVPluginTracker::LoadPluginConfigurationXMLConf(std::string const&, std::string const&) + 819
14 0x7f0f1539f3cf vtkPVPluginTracker::LoadPluginConfigurationXML(char const*, bool) + 495
13 0x7f0f1539de3c vtkPVPluginTracker::LoadPluginConfigurationXMLHinted(vtkPVXMLElement*, char const*, bool) + 6220
12 0x7f0f15392083 vtkPVPluginLoader::LoadPluginInternal(char const*, bool) + 4227
11 0x7f0f15390474 vtkPVPluginLoader::LoadPluginInternal(vtkPVPlugin*) + 948
10 0x7f0f1538f16c vtkPVPlugin::ImportPlugin(vtkPVPlugin*) + 1436
9 0x7f0f1539bb1f vtkPVPluginTracker::RegisterPlugin(vtkPVPlugin*) + 1551
8 0x7f0f135b3644 /usr/local/lib/libvtkCommonCore-pv5.9.so.1(+0x440644) [0x7f0f135b3644]
7 0x7f0f15fc0791 vtkObject::vtkClassMemberCallback::operator()(vtkObject*, unsigned long, void*) + 113
6 0x7f0f15fb9355 vtkSIProxyDefinitionManager::HandlePlugin(vtkPVPlugin*) + 469
5 0x7f0f17ea3cac /lib/x86_64-linux-gnu/libc.so.6(+0x99cac) [0x7f0f17ea3cac]
4 0x7f0f17ea247c /lib/x86_64-linux-gnu/libc.so.6(+0x9847c) [0x7f0f17ea247c]
3 0x7f0f17e9a3ee /lib/x86_64-linux-gnu/libc.so.6(+0x903ee) [0x7f0f17e9a3ee]
2 0x7f0f17e2f859 abort + 299
1 0x7f0f17e5018b gsignal + 203
0 0x7f0f17e50210 /lib/x86_64-linux-gnu/libc.so.6(+0x46210) [0x7f0f17e50210]
( 1.166s) [paraview ] :0 FATL| Signal: SIGABRT
Aborted (core dumped)

Did I miss some steps?

Regards

Hi @y.juntao , thanks for trying the PV connector on Ubuntu. I have a couple of suggestions for what may be the cause of the issues you’re seeing:

  • As you probably know, the PVOV_INSTALL_PATH export has to be in the same environment as the running launcher instance, generally by running something like PVOV_INSTALL_PATH="~/Downloads/ParaView-5.9.0-MPI-Linux-Python3.8-64bit" ~/Downloads/omniverse-launcher-linux.AppImage. However, if you already had a Launcher instance running before, and closed it by clicking the cross in the gui, it is still running in the background. When you try to then run the launcher again from another terminal, it actually reopens the previous instance and the PVOV_INSTALL_PATH is likely not set. Only by clicking the launcher icon on the top-right of the screen and pressing Exit, is the instance actually shut down.

  • Running the installer independently from the launcher can work, but the result won’t feed back into the launcher itself. I’m not sure why it’s trying to install to /usr/local though, or even completing without errors but crashing afterwards. I’d make sure ParaView is of version 5.9.0 (from here) and simply extracted somewhere under the home directory to avoid access problems, like ~/<install-dir-of-choice>, to where you can then set the PVOV_INSTALL_PATH.

Hopefully these two suggestions will fix your problems with the PV Connector’s install process, but if not, just let me know!

Cheers,
Kees

Thanks Kees,

I compiled paraview from source to /usr/local. But the binary version given by you works for me now.

Cheers

@kvankootenwj0rw , Hi, Kees, After successful installation, I ran into another problem with connecting to Omniverse local server.

First, I could not start paraview without root access. If I do not start paraview with sudo, I’ll get the following error.

AutoMPI: SUCCESS: command is:
 "/home/juntao/Downloads/ParaView-5.9.0-MPI-Linux-Python3.8-64bit/bin/mpiexec" "-n" "6" "/home/juntao/Downloads/ParaView-5.9.0-MPI-Linux-Python3.8-64bit/bin/pvserver" "--server-port=42441"
AutoMPI: starting process server
-------------- server output --------------
Waiting for client...
AutoMPI: server successfully started.
(  30.416s) [paraview        ]         vtkSIProxy.cxx:422    ERR| vtkSIProxy (0x1a186d0): Failed to create 'vtkPVOmniConnectSettings'. This typically means that ParaView does not know about the request class to create an instance of if. Ensure that it has been correctly wrapped using the client-server wrappers and the wrapping has been initialized. Note class names are case-sensitive. Check for typos. Aborting for debugging purposes.

Loguru caught a signal: SIGABRT
Stack trace:
37            0x407b2a /home/juntao/Downloads/ParaView-5.9.0-MPI-Linux-Python3.8-64bit/bin/paraview-real() [0x407b2a]
36      0x7fe19d1700b3 __libc_start_main + 243
35            0x40776d /home/juntao/Downloads/ParaView-5.9.0-MPI-Linux-Python3.8-64bit/bin/paraview-real() [0x40776d]
34            0x40c6d0 /home/juntao/Downloads/ParaView-5.9.0-MPI-Linux-Python3.8-64bit/bin/paraview-real() [0x40c6d0]
33            0x408978 /home/juntao/Downloads/ParaView-5.9.0-MPI-Linux-Python3.8-64bit/bin/paraview-real() [0x408978]
32      0x7fe19cdf5a19 pqParaViewBehaviors::pqParaViewBehaviors(QMainWindow*, QObject*) + 1049
31      0x7fe19cd68366 pqAlwaysConnectedBehavior::pqAlwaysConnectedBehavior(QObject*) + 310
30      0x7fe19cd681ee pqAlwaysConnectedBehavior::serverCheck() + 174
29      0x7fe19b76275d pqObjectBuilder::createServer(pqServerResource const&, int) + 605
28      0x7fe1999c4246 vtkSMSession::ConnectToSelf(int) + 70
27      0x7fe1999c3510 vtkSMSession::ConnectToRemoteInternal(char const*, int, bool, int) + 1040
26      0x7fe198be0388 vtkProcessModule::RegisterSession(vtkSession*) + 376
25      0x7fe193f0d102 /home/juntao/Downloads/ParaView-5.9.0-MPI-Linux-Python3.8-64bit/bin/../lib/libvtkCommonCore-pv5.9.so.1(+0x3f3102) [0x7fe193f0d102]
24      0x7fe193d94209 vtkCallbackCommand::Execute(vtkObject*, unsigned long, void*) + 25
23      0x7fe199eccf10 /home/juntao/Downloads/ParaView-5.9.0-MPI-Linux-Python3.8-64bit/bin/../lib/libvtkGUISupportQt-pv5.9.so.1(+0x39f10) [0x7fe199eccf10]
22      0x7fe199eb92ab /home/juntao/Downloads/ParaView-5.9.0-MPI-Linux-Python3.8-64bit/bin/../lib/libvtkGUISupportQt-pv5.9.so.1(+0x262ab) [0x7fe199eb92ab]
21      0x7fe19a6191ea QMetaObject::activate(QObject*, int, int, void**) + 1850
20      0x7fe19b6f87b9 /home/juntao/Downloads/ParaView-5.9.0-MPI-Linux-Python3.8-64bit/bin/../lib/libpqCore-pv5.9.so.1(+0x7a7b9) [0x7fe19b6f87b9]
19      0x7fe19b6f54f2 pqServerManagerObserver::connectionCreated(long long) + 50
18      0x7fe19a6191ea QMetaObject::activate(QObject*, int, int, void**) + 1850
17      0x7fe19b7af40d pqServerManagerModel::onConnectionCreated(long long) + 637
16      0x7fe1999737c6 vtkSMParaViewPipelineController::InitializeSession(vtkSMSession*) + 374
15      0x7fe19996efd2 vtkSMParaViewPipelineController::UpdateSettingsProxies(vtkSMSession*) + 546
14      0x7fe190670360 vtkSMParaViewPipelineControllerWithRendering::PostInitializeProxy(vtkSMProxy*) + 48
13      0x7fe199973da3 vtkSMParaViewPipelineController::PostInitializeProxy(vtkSMProxy*) + 163
12      0x7fe19999487d vtkSMProxy::UpdateVTKObjects() + 29
11      0x7fe1999e6d22 vtkSMSettingsProxy::CreateVTKObjects() + 34
10      0x7fe199995013 vtkSMProxy::CreateVTKObjects() + 1091
9       0x7fe1999c9a1b vtkSMSessionClient::PushState(paraview_protobuf::Message*) + 379
8       0x7fe1998bb255 vtkPVSessionBase::PushState(paraview_protobuf::Message*) + 37
7       0x7fe1998c0179 vtkPVSessionCore::PushState(paraview_protobuf::Message*) + 73
6       0x7fe1998bf9fc vtkPVSessionCore::PushStateInternal(paraview_protobuf::Message*) + 700
5       0x7fe1998e1664 vtkSIProxy::Push(paraview_protobuf::Message*) + 36
4       0x7fe1998e088c vtkSIProxy::InitializeAndCreateVTKObjects(paraview_protobuf::Message*) + 6604
3       0x7fe1998e1c1b vtkSIProxy::CreateVTKObjects() + 763
2       0x7fe19d16e859 abort + 299
1       0x7fe19d18f18b gsignal + 203
0       0x7fe19d18f210 /lib/x86_64-linux-gnu/libc.so.6(+0x46210) [0x7fe19d18f210]
(  30.470s) [paraview        ]                       :0     FATL| Signal: SIGABRT
error: exception occurred: Child aborted

I found I could proceed with sudo ./paraview, but I get the following error when trying to connect to Omniverse from paraview.

[sudo] password for juntao: 
VisRTX 0.1.6, using devices:
 0: NVIDIA RTX A6000 (Total: 51.0 GB, Available: 49.9 GB)
(   3.556s) [paraview        ]    vtkOutputWindow.cxx:106   INFO| Omniverse Connector Qt plugin loaded
Running Firefox as root in a regular user's session is not supported.  ($XAUTHORITY is /run/user/1000/gdm/Xauthority which is owned by juntao.)
Running Firefox as root in a regular user's session is not supported.  ($XAUTHORITY is /run/user/1000/gdm/Xauthority which is owned by juntao.)
Running Firefox as root in a regular user's session is not supported.  ($XAUTHORITY is /run/user/1000/gdm/Xauthority which is owned by juntao.)
/usr/bin/xdg-open: 869: iceweasel: not found
/usr/bin/xdg-open: 869: seamonkey: not found
/usr/bin/xdg-open: 869: mozilla: not found
/usr/bin/xdg-open: 869: epiphany: not found
/usr/bin/xdg-open: 869: konqueror: not found
mkdir: cannot create directory '/run/user/0': Permission denied
[296200:296200:0202/135449.464844:ERROR:zygote_host_impl_linux.cc(90)] Running as root without --no-sandbox is not supported. See https://crbug.com/638180.
/usr/bin/xdg-open: 869: chromium-browser: not found
/usr/bin/xdg-open: 869: google-chrome: not found
/usr/bin/xdg-open: 869: www-browser: not found
/usr/bin/xdg-open: 869: links2: not found
/usr/bin/xdg-open: 869: elinks: not found
/usr/bin/xdg-open: 869: links: not found
/usr/bin/xdg-open: 869: lynx: not found
/usr/bin/xdg-open: 869: w3m: not found
xdg-open: no method available for opening 'http://localhost:3180/?redirect=http://localhost:4040/api/auth&server=localhost:3180'
(  18.584s) [paraview        ]    vtkOutputWindow.cxx:76     ERR| Omniverse error: Server connection cannot be established, errorcode:eOmniClientResult_ErrorConnection


(  18.600s) [paraview        ]    vtkOutputWindow.cxx:76     ERR| Omniverse error: Omniverse Connection initialization error, Omniverse Connector stopping. 

There seems to be some permission denied errors, but I already started paraview with sudo.

Regards

Edit: It seems like you’re enabling Auto-MPI, which is not recommended anymore: Remove AutoMPI? - Development - ParaView. If you want to use an MPI-enabled client-server setup, my answer below should help.


If you’re using an MPI-enabled client-server setup for Paraview, and somewhere along the line the Omniverse Connector plugin is not loaded correctly. This shouldn’t be due to sudo rights, everything has to work correctly without (and any install should also be performed as a normal user).

For me, when I press the Connect button in the PV client and connect to a server, the plugin is automatically loaded and when I then navigate to Tools->Manage Plugins I can see the OmniverseConnector as loaded in both the local and the remote plugins list. Of course, the client and server instance both have to be run from a PV install that includes the PV connector’s libraries.

Hi, Kees

Thank you. It works after turn off auto-MPI.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.