difficulties with Cuda 10.1 on GeForce 2080 Ti


before upgrading my workstation I was using Cuda 9.0 on a GeForce 960 GTX.
I could smoothly develop my project with Visual Studio 2015.

Now I tried to work with Cuda 10.1 / GeForce 2080 Ti / Visual Studio 2019 and
I experienced severe problems. A short summary:

  • nvcc runs timeout during compiling my project in release mode and using the option “relocatable device code” (in debug mode it worked);
  • I’m forced to use the Next-Gen-Debugger but actually it does not feel “Next-Gen” because I cannot enable memcheck
  • breakpoints in device code are not triggered properly even if kernels are called with one block and one thread
  • I got strange illegalAddressErrors in device code, for example,
auto numParticles = data.entities.particles.getNumber();

led to an error, but

auto const& particles = data.entities.particles;
auto numParticles = particles.getNumber();

worked fine

  • in case a breakpoint is triggered, the values and addresses of the variables are not shown OR are even wrong (especially for bool values)

I use the newest display driver.
All those problems didn’t occur on my previous system.

So my questions are: Are the problems well-known? Have I forgotten something crucial after setting up my new working environment?

Thank you in advance for any help!