DIGITS: CAFFE_ROOT does not point to a valid installation of Caffe

Hi:
Im using Ubuntu 16.04 with a GTX 860M

I have installed CUDA 10, cuDNN 7.3, NVCaffe 0.15 and DIGITS 6.1.1. When I try to run DIGITS it shows me this error:

"/usr/home/jetson/caffe/" from CAFFE_ROOT does not point to a valid installation of Caffe.
Use the envvar CAFFE_ROOT to indicate a valid installation.
Traceback (most recent call last):
  File "/usr/lib/python2.7/runpy.py", line 174, in _run_module_as_main
    "__main__", fname, loader, pkg_name)
  File "/usr/lib/python2.7/runpy.py", line 72, in _run_code
    exec code in run_globals
  File "/home/jetson/DIGITS/digits/__main__.py", line 70, in <module>
    main()
  File "/home/jetson/DIGITS/digits/__main__.py", line 53, in main
    import digits.config
  File "digits/config/__init__.py", line 7, in <module>
    from . import (  # noqa
  File "digits/config/caffe.py", line 226, in <module>
    executable, version, flavor = load_from_envvar('CAFFE_ROOT')
  File "digits/config/caffe.py", line 33, in load_from_envvar
    % executable_dir)
ValueError: Caffe executable not found at "/usr/home/jetson/caffe/build/tools"

I have check that in /usr/home/jetson/caffe/build/tools is a caffe executable file.
And when I echo $CAFFE_ROOT the result is the correct I think:

/usr/home/jetson/caffe

I have installed Caffe with no problems and make runtest was succesfull, also make pycaffe.

Why I am getting this error? Is a incompatibility version problem of something I have installed like CUDA or DIGITS?

Thanks for the help!

what does your caffe executable file look like?

I had the same error. You can use docker for it. When you download the container (DIGITS), there are caffe inside of the container.

ex:
sudo apt-get install docker

and after login in NVidia GPU Cloud and run with docker

sudo docker login nvcr.io
sudo docker pull nvcr.io/nvidia/digits:19.03-caffe

and run …

sudo docker run -d -p 5000:5000 -it --rm nvcr.io/nvidia/digits:19.03-caffe

In addition to the caffe executables, DIGITS also depends on the python binding of caffe. The DIGITS containers come with all configurations and tools ready to use, and are much easier to use.

For this issue, can you check if pycaffe is built (ie make pycaffe)?

I’m working on a video tutorial that addresses this problem. There are two reasons for it.

  1. The version of caffe/nvcaffe you are using is wrong. DIGITS only works with .15

  2. When building caffe/nvcaffe you need to use CMAKE, but a later version than the one you would get from the repository. You need CMAKE version 3.12.2 if I remember correctly. The one that comes from the standard repository is 3.10, which is incorrect and can cause the error.

Again, I’m working on a video tutorial that walks you through the entire process. I am using Ubuntu 18.04 LTS as the host machine, creating the model etc. then pushing it to the Jetson Xavier. I know they say that you are not supposed to use that version of Ubuntu, but it worked out for me (plus I need that version to interface properly with the Jetson Xavier and the JetPack etc.)

There are a lot of moving parts with this one, so it really could be anything, but try those approaches for now. Anyway check out cudaeducation.com for tutorials on CUDA, Jetson Xavier, TensorFlow etc. I will post the video tutorial there once I finish it.

Hope this helps!

-Cuda Education
cudaeducation.com

DISCLAIMER: Use at your own risk! This code and/or instructions are for teaching purposes only. CUDA Education does not guarantee the accuracy of this code in any way. The code and instructions on this site may cause hardware damage and/or instability in your system. This code and/or instructions should not be used in a production or commercial environment.

Any liabilities or loss resulting from the use of this code and/or instructions, in whole or in part, will not be the responsibility of CUDA Education. All rights reserved. This code is the property of CUDA Education. Please contact CUDA Education at cudaeducation@gmail.com if you would like to use this code in any way, shape or form.

A video walkthrough of natively installing NVIDIA DIGITS on Ubuntu 18.04 LTS is available here:
https://cudaeducation.com/nvidiadigits/

-Cuda Education
cudaeducation.com