DIGITS / CAFFE_ROOT problem

Hi,

I have installed DIGITS on Ubuntu 16.04 regarding the NVIDIA/DIGITS. When I run

./digits-devserver

output becomes:

"/home/deep/caffe" from CAFFE_ROOT does not point to a valid installation of Caffe.
Use the envvar CAFFE_ROOT to indicate a valid installation.
Traceback (most recent call last):
  File "/usr/lib/python2.7/runpy.py", line 174, in _run_module_as_main
    "__main__", fname, loader, pkg_name)
  File "/usr/lib/python2.7/runpy.py", line 72, in _run_code
    exec code in run_globals
  File "/home/deep/digits/digits/__main__.py", line 70, in <module>
    main()
  File "/home/deep/digits/digits/__main__.py", line 53, in main
    import digits.config
  File "digits/config/__init__.py", line 7, in <module>
    from . import (  # noqa
  File "digits/config/caffe.py", line 226, in <module>
    executable, version, flavor = load_from_envvar('CAFFE_ROOT')
  File "digits/config/caffe.py", line 37, in load_from_envvar
    import_pycaffe(python_dir)
  File "digits/config/caffe.py", line 126, in import_pycaffe
    import caffe
  File "/home/deep/caffe/python/caffe/__init__.py", line 1, in <module>
    from .pycaffe import Net, SGDSolver, NesterovSolver, AdaGradSolver, RMSPropSolver, \
  File "/home/deep/caffe/python/caffe/pycaffe.py", line 15, in <module>
    import caffe.io
  File "/home/deep/caffe/python/caffe/io.py", line 8, in <module>
    from caffe.proto import caffe_pb2
  File "/home/deep/caffe/python/caffe/proto/caffe_pb2.py", line 1402, in <module>
    options=_descriptor._ParseOptions(descriptor_pb2.FieldOptions(), _b('

“/home/deep/caffe” from CAFFE_ROOT does not point to a valid installation of Caffe.
Use the envvar CAFFE_ROOT to indicate a valid installation.
Traceback (most recent call last):
File “/usr/lib/python2.7/runpy.py”, line 174, in _run_module_as_main
main”, fname, loader, pkg_name)
File “/usr/lib/python2.7/runpy.py”, line 72, in _run_code
exec code in run_globals
File “/home/deep/digits/digits/main.py”, line 70, in
main()
File “/home/deep/digits/digits/main.py”, line 53, in main
import digits.config
File “digits/config/init.py”, line 7, in
from . import ( # noqa
File “digits/config/caffe.py”, line 226, in
executable, version, flavor = load_from_envvar(‘CAFFE_ROOT’)
File “digits/config/caffe.py”, line 37, in load_from_envvar
import_pycaffe(python_dir)
File “digits/config/caffe.py”, line 126, in import_pycaffe
import caffe
File “/home/deep/caffe/python/caffe/init.py”, line 1, in
from .pycaffe import Net, SGDSolver, NesterovSolver, AdaGradSolver, RMSPropSolver,
File “/home/deep/caffe/python/caffe/pycaffe.py”, line 15, in
import caffe.io
File “/home/deep/caffe/python/caffe/io.py”, line 8, in
from caffe.proto import caffe_pb2
File “/home/deep/caffe/python/caffe/proto/caffe_pb2.py”, line 1402, in
options=_descriptor._ParseOptions(descriptor_pb2.FieldOptions(), _b(’\020\001’)), file=DESCRIPTOR),
TypeError: new() got an unexpected keyword argument ‘file’

20

“/home/deep/caffe” from CAFFE_ROOT does not point to a valid installation of Caffe.
Use the envvar CAFFE_ROOT to indicate a valid installation.
Traceback (most recent call last):
File “/usr/lib/python2.7/runpy.py”, line 174, in _run_module_as_main
main”, fname, loader, pkg_name)
File “/usr/lib/python2.7/runpy.py”, line 72, in _run_code
exec code in run_globals
File “/home/deep/digits/digits/main.py”, line 70, in
main()
File “/home/deep/digits/digits/main.py”, line 53, in main
import digits.config
File “digits/config/init.py”, line 7, in
from . import ( # noqa
File “digits/config/caffe.py”, line 226, in
executable, version, flavor = load_from_envvar(‘CAFFE_ROOT’)
File “digits/config/caffe.py”, line 37, in load_from_envvar
import_pycaffe(python_dir)
File “digits/config/caffe.py”, line 126, in import_pycaffe
import caffe
File “/home/deep/caffe/python/caffe/init.py”, line 1, in
from .pycaffe import Net, SGDSolver, NesterovSolver, AdaGradSolver, RMSPropSolver,
File “/home/deep/caffe/python/caffe/pycaffe.py”, line 15, in
import caffe.io
File “/home/deep/caffe/python/caffe/io.py”, line 8, in
from caffe.proto import caffe_pb2
File “/home/deep/caffe/python/caffe/proto/caffe_pb2.py”, line 1402, in
options=_descriptor._ParseOptions(descriptor_pb2.FieldOptions(), _b(’\020\001’)), file=DESCRIPTOR),
TypeError: new() got an unexpected keyword argument ‘file’

01')), file=DESCRIPTOR),
TypeError: __new__() got an unexpected keyword argument 'file'

For a long time, I am trying to solve problems by googling but could not find any solution. I just want to use DIGITS anymore. I hope this is my last problem and will solve with your helps.

Thanks in advance, Ender.

How did you install DIGITS?

What version of numpy do you have on your system:

% python -c ‘import numpy as np; print(np.version)’

Did you try to upgrade your numpy?

% pip install numpy --upgrade

I reinstalled ubuntu system since my system was messed up. In addition, I had two different numpy and
also upgraded numpy but never worked. I am probably installing wrong prerequisites for DIGITS and I do not know if they are the correct versions. For example, I installed CUDA 9.1, cuDNN7.1 and so on. This time I am thinking of installing old versions. For example, CUDA 8, cudnn 5.1 and etc. Do you think it is the right decision?

This looks like an issue on protobuf version mismatch. You might have built caffe with a version of protobuf, but when you ran DIGITS with caffe, caffe loaded another protobuf lib.

Thank you for the reply. I solved the problem by reinstalling all packages such as; Cuda-9.0, cuDNN 7.0, cafe 0.15 and tensorflow 1.17. After reinstalling, I learned that installing wrong version of packages caused this problem since DIGITS 6.1.1 works with these reinstalled packages.

A video walkthrough of natively installing NVIDIA DIGITS on Ubuntu 18.04 LTS is available here:

https://cudaeducation.com/nvidiadigits/

-Cuda Education
cudaeducation.com