DIGITS install failing...

Hi I’m new to using NGC so please forgive me if I’ve missed something silly, but when I try to pull DIGITS part way through the install I get this…


b1172b11697c: Downloading 79.33MB/98.95MB
f7d4e939e2f3: Download complete
69fd65e359c1: Downloading 14.57MB/183.6MB
b3073cb6c892: Downloading
cd3cfb41069b: Waiting
60741008fcc3: Waiting
6bf9ad071f73: Waiting
c3cfc72a0228: Waiting
e5f682d39d70: Waiting
c6dc998f001d: Waiting
0789191dcf7e: Waiting
f502b222f40f: Waiting
2eb32606ef18: Waiting
78768428f5ae: Waiting
4ab52b2195eb: Waiting
2c27729d0333: Waiting
unauthorized: authentication required

What am I missing??? (this is on a DGX-1)

Likely, you ran into a docker download issue. Please try again.
Your dock pull request should produce the msgs like below:

b1172b11697c: Pull complete
f7d4e939e2f3: Pull complete
69fd65e359c1: Pull complete
b3073cb6c892: Pull complete
cd3cfb41069b: Pull complete
60741008fcc3: Pull complete
6bf9ad071f73: Pull complete
c3cfc72a0228: Pull complete
e5f682d39d70: Pull complete
c6dc998f001d: Pull complete
0789191dcf7e: Pull complete
f502b222f40f: Pull complete
2eb32606ef18: Pull complete
78768428f5ae: Pull complete
4ab52b2195eb: Pull complete
2c27729d0333: Pull complete
Digest: sha256:e96ec71df017ec7f3b44deca05b2e1ccedecb6887c09f4d643f186a276f93bdb
Status: Downloaded newer image for nvcr.io/nvidia/digits:18.10

Hmm I still can’t seem to pull the DIGITS container… same as before, part way through the pull I get unauthorized: authentication required

I can pull and use the CUDA container without any issues, so it’s not docker or the drivers. I’m not sure what to try next?

Ok fixed it with the following

sudo systemctl daemon-reload
sudo systemctl restart docker

Use docker with sudo or try again with root.

ex.: sudo docker pull…

Another way is to add the user into docker group, as mentioned in this document, https://docs.docker.com/install/linux/linux-postinstall/.

I am having a similar problem while trying to download digits from NGC.
The following error comes…
1db62adda970: Waiting
f0d09f10c9d9: Waiting
9b69656fe699: Waiting
401bb3cd44e9: Waiting
eba576ca18ba: Waiting
7a6c68aeeb93: Waiting
96182c2dc7c4: Waiting
docker: error pulling image configuration: Get https://docker-registry-data-prod.s3-us-west-1.amazonaws.com/registry/docker/registry/v2/blobs/sha256/82/828544268d993844a5a95b0de08228652efe28885296b579fd6ea92de8771abc/data?X-Amz-Algorithm=AWS4-HMAC-SHA256&X-Amz-Credential=AKIAJ4J66VTANWO2KIWA%2F20190527%2Fus-west-1%2Fs3%2Faws4_request&X-Amz-Date=20190527T033959Z&X-Amz-Expires=1200&X-Amz-SignedHeaders=host&X-Amz-Signature=9e70c9a8a31a197bd36b9e0bdccb061b528ec2a79d24d158d7fa37329eb38279: dial tcp: lookup docker-registry-data-prod.s3-us-west-1.amazonaws.com on 127.0.1.1:53: read udp 127.0.0.1:34660->127.0.1.1:53: i/o timeout.

Have you tried this…

sudo systemctl daemon-reload
sudo systemctl restart docker

Then pull digits

Thank you…It was an issue with poor internet connection. I could resolve it. Thanks again…

A video walkthrough of natively installing NVIDIA DIGITS on Ubuntu 18.04 LTS is available here:

https://cudaeducation.com/nvidiadigits/

-Cuda Education
cudaeducation.com