Disable debug printouts and get access to /dev/ttyS0

How to disable debug printouts to /dev/ttyS0 device and work with /dev/ttyS0:

  1. open file “Linux_for_Tegra/source/public/hardware/nvidia/platform/t210/jetson/kernel-dts/tegra210-porg-p3448-common.dtsi”.

  2. Comment string “console-port;” in section “serial@70006000”. Example:

	serial@70006000 { /* UART-A : UART1: Debug */
		compatible = "nvidia,tegra210-uart", "nvidia,tegra114-hsuart", "nvidia,tegra20-uart";
		/* console-port; */
		sqa-automation-port;
		/delete-property/ resets;
		/delete-property/ reset-names;
		status = "okay";
	};
  1. Compile the device tree.

  2. Flash the device tree to the Jetson Nano device.

  3. In Jetson Nano box open file “/boot/extlinux/extlinux.conf”.

  4. Delete string APPEND ${cbootargs} quiet root=/dev/mmcblk0p1 rw rootwait rootfstype=ext4 console=ttyS0,115200n8 console=tty0 fbcon=map:0 net.ifnames=0 sdhci_tegra.en_boot_part_access=1.

  5. Insert string APPEND tegraid=21.1.2.0.0 ddr_die=4096M@2048M section=512M memtype=0 vpr_resize usb_port_owner_info=0 lane_owner_info=0 emc_max_dvfs=0 touch_id=0@63 video=tegrafb no_console_suspend=1 maxcpus=4 usbcore.old_scheme_first=1 lp0_vec=0x1000@0xff780000 core_edp_mv=1075 core_edp_ma=4000 gpt tegra_fbmem=0x800000@0x92cb4000 is_hdmi_initialised=1 root=/dev/mmcblk0p1 rw rootwait rootfstype=ext4 console=tty0 fbcon=map:0 net.ifnames=0 sdhci_tegra.en_boot_part_access=1 quiet root=/dev/mmcblk0p1 rw rootwait rootfstype=ext4 console=tty0 fbcon=map:0 net.ifnames=0 sdhci_tegra.en_boot_part_access=1

  6. Save file and reboot the Jetson Nano box.

After that actions /dev/ttyS0 works well.

1 Like

Thanks for your sharing about the steps to disable debug messages and use it as normal UART on Jetson Nano.

You are welcome!

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.