Disable output to pin 8 / UART1_TXD on J6/J41 header during boot

I have a Jetson Nano B01 with a motor driver connected to the serial port /dev/ttyTHS1 on pins 8 on the J6 connector. I also see this connector referenced as J41, so I’m not sure what the correct number is. It is the big 40 pins connector.

Everything works, however, during boot something happens on that pin that triggers the motor driver to start. If I connect the motor driver after bootup, it’s fine. It’s only during the boot process.

It looks like some data is sent to that pin, but I’m not sure what exactly. Initially I though it was the serial console, but that is not the case. The serial console is running on the other UART.

Things I tried:

  • Tried running the motor driver on the UART on the other connector (/dev/ttyS0). This connector does indeed expose the serial console
  • Stop and disable the nvgetty service
  • Removing the console boot args in /boot/extlinux/extlinux.conf. This does not seem to have any effect. From other posts, I’m guessing the console is baked into the kernel and I doubt it would help anyway since it is running on the other connector.

One thing I just realized, do I maybe need an external pull up/down resistor? I can’t find any documentation on that.

please see-also Applications Note for the 40-Pin Expansion Header GPIO Usage Considerations.

If I understand the documentation correctly. There’s really no way to guarantee that no data is sent during the startup/shutdown phase. I’m not entirely sure, but because the ports can act both as input and output and they switch automatically from one to the other a pull down resistor really doesn’t help (depending on the case you need 5k or a 50k resistor)

The motor controller (Sabertooth) also supports a more complicated protocol. One that requires an initialization byte to be sent before it becomes active. I’ve switched to that one which circumvents this issue completely.

Thanks for the links to the application note. I had not found this in my searches.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.