disable USB 3.0 LPM

Problem: I have a USB 3.0 device (Pointgrey Chameleon3 camera) that is getting its USB 3.0 LPM levels U1 and U2 enabled (and this is interfering with proper operation). Perhaps this is a bug in the kernel, because this happens with R23.2.0 but not with R24.2.1. It also only happens (with R23.2.0) when I have the camera connected directly to the TX1, but not when connected via an (unpowered) hub.

Plenty out there on disabling autosuspend (which doesn’t help), but I’m having difficulty finding information on how to disable LPM.

NOTE: Some TX1 info probably applies, but I’m editing to be more specific to the TK1.

There is the performance mode web page which does talk about idle for other areas…this may be at least part of preventing USB suspend/idle (or the particular state you are talking about). See:
http://elinux.org/Jetson/TX1_Controlling_Performance
http://elinux.org/Jetson_TK1#Performance_and_Power_Topics

Here’s the specific case you may have tried, but if not, try this:

sudo echo -1 > /sys/module/usbcore/parameters/autosuspend

Whoops. I meant to put this in the TX1 forum.

Ok, assuming it is TX1 and not TK1, the old crossed out URL applies. Maybe this would apply as well…some USB power states are simply being driven by the USB driver shadowing what the the system state is (if the system doesn’t use certain states, then USB won’t automatically use those states). Try this:

sudo -s
echo 0 > /sys/devices/system/cpu/cpuquiet/tegra_cpuquiet/enable
echo 1 > /sys/kernel/debug/cpuidle_t210/fast_cluster_states_enable
echo 1 > /sys/kernel/debug/cpuidle_t210/slow_cluster_states_enable
exit