Disabling Nouveau drivers to enable use of NVIDIA drivers

I am running CentOS 7, and I am trying to figure out:

  1. What NVIDIA driver do I need?
  2. How to disable the Nouveau driver that is apparently blocking every attemptI make at installing the NVIDIA driver?

I hope the following helps:

$ lspci | grep -i vid
01:00.0 VGA compatible controller: NVIDIA Corporation GP104GLM [Quadro P3200 Mobile] (rev a1)
01:00.1 Audio device: NVIDIA Corporation GP104 High Definition Audio Controller (rev a1)

Help.

Thanks,

Aaron

  1. Follow the wizard at: http://www.nvidia.com/drivers to select the latest driver for your GPU
  2. https://docs.nvidia.com/cuda/cuda-installation-guide-linux/index.html

Note that you might want to study the guide listed in 2 first, before doing anything from 1.

The CUDA linux installers include a bundled driver, and the latest CUDA 10.1.243 includes a bundled driver that may work with your GPU. If not, the latest driver found in step 1 will work for your GPU, and will work with any CUDA version.

When I rebooted, my boot process hung with the message “Started Update UTMP about System Runlevel Changes.”

What do I do?

I don’t really know. You may need to disable secure boot. I don’t have a list of instructions to give you, so if you ask me “what do I do?” I probably won’t respond. However there are instructions all over the web on disabling secure boot. And it may not be a secure boot issue.