Disabling the Display from Kernel

I’m just looking for confirmation here. We have designed a carrier board that doesn’t require any display but uses I2C busses that were previously used for HDMI. To disable the display, (HDMI, Display port, etc), is the following all that is needed?

# .../public/hardware/nvidia/platform/t19x/jakku/kernel-dts/common/tegra194-p3509-disp.dtsi
&sor0 {
	status = "disabled";
	nvidia,active-panel = <&sor0_dp_display>;
};

&sor0_dp_display {
	status = "disabled";
	nvidia,is_ext_dp_panel = <1>;
};

&sor1 {
	status = "disabled";
	nvidia,active-panel = <&sor1_hdmi_display>;
};

&sor1_hdmi_display {
	status = "disabled";
	disp-default-out {
		nvidia,out-flags = <TEGRA_DC_OUT_HOTPLUG_LOW>;
	};
};

Yes, you need to disable display with above device tree.

Thanks for the confirmation @WayneWWW.

Hi @WayneWWW,
It seems that disabling the above in the device tree does still not allow us to access I2C3 and I2C5.

I attempted to follow the solution at: Is I2C5_CLK/DATA, (i2c9 i2c@31e0000) usable? - #6 by lunarking1028, but it is already the default in my device tree tegra194-p3668-common.dtsi.

Commands I’ve been using to check if we can access the I2C addresses
sudo i2cdetect -y -r 3
sudo i2cdetect -y -r 5

i2cdetect error

     0  1  2  3  4  5  6  7  8  9  a  b  c  d  e  f
00:          
[ 2802.522596] tegra-i2c 31b0000.i2c: pio timed out addr: 0x3 tlen:12 rlen:4
[ 2802.522808] tegra-i2c 31b0000.i2c: --- register dump for debugging ----
[ 2802.523099] tegra-i2c 31b0000.i2c: I2C_CNFG - 0x22c00
[ 2802.523218] tegra-i2c 31b0000.i2c: I2C_PACKET_TRANSFER_STATUS - 0x10001
[ 2802.523351] tegra-i2c 31b0000.i2c: I2C_FIFO_CONTROL - 0x0
[ 2802.523477] tegra-i2c 31b0000.i2c: I2C_FIFO_STATUS - 0x800080
[ 2802.523666] tegra-i2c 31b0000.i2c: I2C_MST_FIFO_CONTROL - 0x70000
[ 2802.523837] tegra-i2c 31b0000.i2c: I2C_MST_FIFO_STATUS - 0x800000
[ 2802.523969] tegra-i2c 31b0000.i2c: I2C_MST_PACKET_TRANSFER_CNT - 0x0
[ 2802.524113] tegra-i2c 31b0000.i2c: I2C_INT_MASK - 0x7d
[ 2802.524240] tegra-i2c 31b0000.i2c: I2C_INT_STATUS - 0x2
[ 2802.524398] tegra-i2c 31b0000.i2c: i2c transfer timed out addr: 0x3

Is there something else I need to enable/disable?

I didn’t check the detail. But what to confirm here is

→ If your i2c pin is shared with DP function, then it means you need similar configuration.of the post you shared for pinmux. You mentioned 2 i2c pins here. But the default “tegra194-p3668-common.dtsi” only configure one pin in dpaux3-3. I believe this should be i2c5.

But your error log is from another i2c (i2c3). Thus, have you checked the pinmux of another i2c pin?

Thanks for the help @WayneWWW, I went ahead and added another configuration as you suggested and it worked.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.