Disabling WIFI on Xav NX

During boot, there is a ~2 minute delay while the Xavier NX looks for a WIFI module that doesn’t exist on our custom carrier board. To avoid this delay, we would like to remove the WLAN from boot.

Based on other forum posts, I’ve gathered the following:

  • Disable output-high for wifi-enable
// tegra194-comms.dtsi
	gpio@2200000 {
		wifi-enable {
			gpio-hog;
//			output-high;
			gpios = <TEGRA194_MAIN_GPIO(G, 3) 0>;
			label = "wifi-enable";
			status = "okay";
		};
	};
  • Update status from okay to disabled
// tegra194-comms.dtsi
	bcmdhd_pcie_wlan {
		compatible = "android,bcmdhd_pcie_wlan";
		wlan-pwr-gpio = <&tegra_main_gpio TEGRA194_MAIN_GPIO(G, 3) 0>;
		fw_path = "/vendor/firmware/fw_bcmdhd_4356.bin";
		nv_path = "/vendor/firmware/nvram_4356.txt";
		status = "disabled";
	};
  • Remove the following lines from tegra_defconfig
// tegra_defconfig
CONFIG_BCMDHD=m
CONFIG_BCMDHD_SDIO=y
CONFIG_BCMDHD_PCIE=y
CONFIG_BCM4354=y
CONFIG_BCMDHD_FW_PATH="/lib/firmware/brcm/fw_bcmdhd.bin"
CONFIG_BCMDHD_NVRAM_PATH="/lib/firmware/brcm/nvram.txt"
CONFIG_BCMDHD_HW_OOB=y
CONFIG_DHD_USE_SCHED_SCAN=y
CONFIG_BCMDHD_DISABLE_MCC=y
CONFIG_BCMDHD_PCIE_FW_PATH="/lib/firmware/brcm/fw_bcmdhd_4356.bin"
CONFIG_BCMDHD_PCIE_NVRAM_PATH="/lib/firmware/brcm/nvram_4356.txt"
CONFIG_BCMDHD_PCIE_ES4_NVRAM_PATH="/lib/firmware/brcm/nvram_murata_4359_b1_es4.txt"

Are these steps all that is necessary to disable WLAN?

No, that would not work because that dts is not for Xavier NX… Xavier NX does not use any bcmdhd 4356.

Also, xavier NX does not have wifi card on its module… Only adds-on on the m.2 key E slot. There is no device tree change needed to disable it… Just remove it from the slot and it won’t get enumerated…

We have no wifi card connected, or anything else connected to the M.2 key E slot. Perhaps there is a linux process that runs during bootup that is responsible for the 2 minute delay?

I’m closing this topic due to there is no update from you for a period, assuming this issue was resolved.
If still need the support, please open a new topic. Thanks

I think the first thing to clarify here is

Which jetpack release are you using? How do you know it is “2 min” delay? What is the base you are comparing with? The nv devkit?