Disappearing GPU

Hello all,

I’ve looked around and haven’t found anybody with this problem. I have two GPU’s, a Quadro FX 580 and a Quadro 5000. I’m using the 580 as a display card and the 5000 to compile and run CUDA code. The problem I’m having is that after some (seemingly) successful runs of my relatively straight foward code, the 5000 disappears. Even when I run deviceQuery, I can’t see the card. This problem started when I was using Matlab for Kernel invocations, but then presisted after I converted all the code to C and ran it. I’ve tried running several different codes, including example codes, and they all eventually do the same thing. I also tried to make the card run in TCC mode and the problem still happened.

Does anybody have an idea of what’s going on?



What OS are you running. Could you check the device manager to see if you have an error code on the device when the problem occurs?

Thanks for the reply,

I’m running Windows 7 64-bit. I checked and the device manager shows that both cards are working properly after the one disappears. I’m using driver version for both.


What do you need to do in order to get the device “back on track”?

When this happens, do you get any error for the drivers as a popup in the lower right corner?

I have to completely reset the computer in order to use the card again. I did see where people were having issues with Windows complaining about a thread taking too long, but I don’t get any errors. Could it still be a problem with Windows, even without the error popups?

Ok, so here’s an update. Maybe this will help…

I’ve tried running the code once successfully, and then leaving the computer alone for a while. When I come back, the card has disappeared, so it seems to have a “timer” on it after the first successful run of the code. Also, after the card as disappeared, I tried running the code on the 580, and it runs successfully every time. I left the machine on all weekend and the 580 still works… Could I have a defective card?

Thanks again

Hi, the problem sounds strange. The strangest thing would be that the card is still visible under device manager as working. It could indeed be a bad card. It could also be a bad PSU but i am only guessing.

Ok, thanks for the help on this. I’ll try to troubleshoot some hardware issues and I’ll post the solution (if I ever find one).

Thanks again,

Hi, a couple of things that you could try:

  1. Test Quadro 5000 in another computer.

  2. Test Quadro 5000 standalone in your computer with the monitor attached.

  3. Swap PCI-e places of Quadro 5000 and FX card and use the 5000 as the display adapter.

I actually had a hard drive with windows vista 64 on it, so I put it in and installed the newest drivers and cuda 4.1 and it works great. I’m going to switch back to 7 and reinstall the drivers (again) and see if it works. I’ll post back with the results.