Display driver failed installation with CUDA 5.0

I’m installing CUDA 5.0 on a Supermicro Quad-GPU machine equipped with 4 K20 GPUs. The manifacturer has installed the 307.45-quadro-tesla-win8-win7-winvista-64bit-international-whql driver. I have then passed to install CUDA5.0. During the execution, the setup program did not ask me anything about the installation of the graphics driver or SDK. The installation has then reported an issue when installing the graphics driver (Display driver failed installation).

Some SDK examples and my own codes not requiring graphics (as DeviceQuery) seem to work correctly. Some others requiring graphics (as oceanFFT) do not. In particular, oceanFFT returns: “Support for necessary OpenGL extensions missing”. I have re-installed the 307.45 graphics driver, but it did not help.

Could you please help me solving the problem?

Hi JFSebastian,

The installation has then reported an issue when installing the graphics driver (Display driver failed installation).

Can you be more specific on the exact issues you’ve encountered?
I’d advise downloading CUDA 5.0 toolkit package (which already contains driver within it) from https://developer.nvidia.com/cuda-downloads
Let me know if you find any problems installing this package. E.g. screenshot with the error would be helpful.

Some SDK examples and my own codes not requiring graphics (as DeviceQuery) seem to work correctly. Some others requiring graphics (as oceanFFT) do not.

Tesla K20 are devices designed for running compute applications and by default don’t allow running any graphics accelerated workloads only compute workloads (e.g. from CUDA).
Some models of Tesla K20 allow changing this default setting (called GOM - GPU Operation Mode) and re-enable graphics acceleration. You can check if your board supports that using tool called nvidia-smi.

Can you run nvidia-smi -q and send me the output? Just run

cd C:Program FilesNVIDIA CorporationNVSMI
	nvidia-smi -q > nvsmi.txt

and attach nvsmi.txt

When you just run nvidia-smi -q (without “> nvsmi.txt” part) search output for property GPU Operation Mode.
If use see:

GPU Operation Mode
        Current                 : N/A
        Pending                 : N/A

Then you’re board doesn’t support changing GOM and it’s a compute only board

If you see:

GPU Operation Mode
        Current                 : Compute
        Pending                 : Compute

Than you can change GOM. Just switch to Administrator user (or just run console with Administrator privileges):

nvidia-smi --gom=ALL_ON

Than enable WDDM driver model (TCC is only for compute tasks):

nvidia-smi --force-driver-model=WDDM

And reboot the system.

Be aware that enabling graphics acceleration on this board might increase its power consumption and thus affect its performance in some situations.

Thanks,
Sean

In addition to what Sean said, regarding the failed display driver installation, there should be a start menu entry called “NVIDIA Display Driver Setup”. Try using this start menu entry to install the driver. The error message you get from the .msi is a generic message.

Thanks for your replies.

Here is some more piece of information.

  1. I’m already using the full CUDA 5.0 toolkit package (containing the driver). Attached is a screenshot of the error returned by the installation.

  2. I have checked the nvidia-smi and it says

GPU Operation Mode
        Current                 : N/A
        Pending                 : N/A

so the cards are compute only ones. Attached is a screenshot of the nvsmi.txt log file.

  1. I have manually reinstalled the graphics driver using the setup file contained in the folder C:NVIDIADisplayDriver307.45Win8_WinVista_Win7_64International. It installs correctly. The only problem was to automatically install it by the CUDA 5.0 toolkit package and receive the graphical outputs of, for instance, the SDK samples.

In conclusion, if I understand correctly, oceanFFT for example will never give any graphical output on my machine, right?

Thank you again.

Display_driver_installation_error.PNG

Display_driver_installation_error.PNG

Needless to say, the monitor is plugged to the video output of the main board, as the K20’s do not have any video output. This notwithstanding, I could not have any graphical outcome on this machine, right?

K20 was launched after CUDA 5.0 toolkit release so the driver packaged in CUDA 5.0 does not contain support for K20, that’s the main reason you are seeing unable to install driver error message in the CUDA 5.0 installer. You can still install CUDA 5.0 but please skip the install of the driver, I think the current state of the system may be just that you have the CUDA5.0 with the correct 307.45 driver that came with the system. You can always pick the latest driver from www.nvidia.com/drivers in future.

Since the K20s in your system are compute only locked SKUs as confirmed with nvsmi, you cannot create any graphics context on those and thus you cannot run any OGL interop samples like OceanFFT. What you could do is get a smaller graphics capable NVIDIA GPU to which you can connect your monitor and run your active desktop on, that will let you to run OGL interop CUDA samples.

Thank you very much for your reply. This definitely clarifies the situation.