Display freezes: (EE) NVIDIA(GPU-0): WAIT

@generix Thanks for your suggestion regarding the brightness.

Regarding the original bug. The bug prevents me from using an external display. As graphical applications on the external display will use the NVIDIA GPU instead of the integrated AMD GPU.

So a long term solution is really desired.

I’m facing the exact same issue as @MatthijsBurgh
Configuration also pretty much the same:
Ubuntu 20.04
AMD Ryzen 5 5800H
Nvidia Geforce RTX3050
HP Pavilion 15 laptop
No external screen.

When changing windows, tabs, etc. the 5-7 sec freezes happen. Freezes are perfectly in sync with the log message:

gru 06 18:31:27 damian-HP /usr/lib/gdm3/gdm-x-session[1583]: (EE) NVIDIA(GPU-0): WAIT (2, 8, 0x8000, 0x00042194, 0x0004219c)
gru 06 18:31:34 damian-HP /usr/lib/gdm3/gdm-x-session[1583]: (EE) NVIDIA(GPU-0): WAIT (1, 8, 0x8000, 0x00042194, 0x0004219c)

I checked 495 and 470 drivers. Both give the same symptoms. Also from time to time, the freeze is permanent (especially coming back from hibernation), in which case I must reboot.

How do I switch to the hybrid mode, to at least get rid of these symptoms?

Attaching the log.
nvidia-bug-report.log (211.1 KB)


To switch to hybride mode:

  • Open Nvidia X server settings
  • In the left list, go to Prime Profiles
  • Select Hybride Mode in the right part of the window.
  • Reboot

As mentioned, an external display will force the X Server to be run by Nvidia again. Which will bring back the issues. Running apps with Nvidia will not result in any issues.

Thanks Matthijs!
I ended up switching off the Nvidia card completely (called “power saving mode”, also your “hybrid” is called “Nvidia On-Demand” in my system). This seems to at least fix the brightness issue (when reviving from suspend), and I don’t need the gpu for other tasks atm…

Now after suspend my mouse stops working, but that I think is unrelated :)

Anyway, a long-term solution would be great to see :/

1 Like

@generix I have updated my driver to 510. The issue is still present.

Also the Prime Profiles settings option is not visible anymore in the Nvidia X Server app. So i don’t know how to switch to Pure Nvidia, Hybrid or pure integrated GPU mode.

1 Like

The “prime profiles” pane in nvidia settings is a ubuntu patched version. If they forgot it, you can run
sudo prime select nvidia (or on-demand, intel)
to switch between modes.
Since with hybrid graphics, both gpu drivers have to work properly together, this might as well the amdgpu driver blocking the nvidia gpu. Seems Ubuntu 20.04 has now upgraded the kernel to 5.13 (with this also the amdgpu driver). Did you already try with that?
Please also check for a bios update.

Thanks for the info about prime-select. That does the job too.

I have also tried the 5.13 kernel in combination with the 510 driver. But the sadly the problem remains. Also the bios is up-to-date.


I am now running kernel 5.16.10, which fixes the problem. I have tested from 5.16.5 and higher, which all worked. I didn’t test any 5.16.X lower and also didn’t test any 5.14 or 5.15.

The only remaining issue that I have:
When I have selected prime modus ‘on-demand’ and I connect an externel display, the UI becomes really slow. (Except the mouse). I expect the X server should always switch to the NVIDIA gpu when an external display is connected, but it doesn’t.
A semi permanent workaround is to just switch to performance mode, though this forces all processes to use the NVIDIA GPU, which reduces the available GPU memory for my AI application.

Please set kernel parameter

Sadly the kernel parameter didn’t change the behaviour.

Hi, I’m on Kernel v5.16.15 and Nvidia 510.54. I’m on an RTX 3050 Ryzen 5 5600H HP Laptop, and I’m getting the freezing issues. I checked the logs and it was mentioning the same WAIT warning. It happens on performance mode when Nvidia GPU is being used. I do not want to use On-demand as my iGPU is not powerful enough.

Is there a fix for this? I’m on ZorinOS 16.1

Any updates on this? External monitor is impossible to use on this machine because of this bug. Everything just freezes and nothing works! I’ve tried updating my kernel and the latest driver but no luck. Please provide a solution if possible!

On-Demand mode does fix the freezes on primary monitor because AMD is being used instead but using an external display is impossible.

I am not sure anymore, but maybe even the last issues, the one related to the external display, were fixed with nvidia driver 520 OR kernel 5.17-5.19.

Though I am back to the freezes. I am now running the following software:
kernel: 6.0.9-060009-generic
nvidia driver: 525.60.13

For now, when I am just using my internal display, running on on-demand, I don’t experience any freezes and my CUDA still works.

@generix I think the issues came back with the 525 driver. I think the 520 driver was still fine.

I’ve been having freezing on 525, just upgraded to 530 to see if it helps, fingers crossed I guess…

Ubuntu 22.04 desktop using “on-demand” to use intel igpu for display so 3090 is dedicated for compute

EDIT: Nah definitely happens again on 530 🙃

1 Like

This saves me some effort. Was going to upgrade. I have been thinking that everyone was happy here. I have 3090 and tried multiple distros and unable to solve this. Just end up powering the machine off at night. Would like to get ths resolved. Just get nvidia wait one resume. using Opensuse Tumbleweed here currently and 525.89.02

Just end less messages after resume.
gdm-x-session[2649]: (WW) NVIDIA(0): WAIT (2-S, 17, 0xb584, 0x000568f0, 0x00056924)
gdm-x-session[2649]: (WW) NVIDIA(0): WAIT (1-S, 17, 0xb584, 0x000568f0, 0x00056924)

I have pretty much the same problem with multiple NVIDIA drivers on PC with nVidia GTX 1050 card, old Gigabyte EP43-DS3 motherboard and Intel Core2 Q9550, multiple Ubuntu versions and kernels

Entry in my syslog appear like the following around the time I have a full lockup

Apr 18 23:57:31 hobbs /usr/libexec/gdm-x-session[2294]: (WW) NVIDIA(0): WAIT (1-S, 17, 0x093b, 0x000034d8, 0x00007f28)
Apr 18 23:57:34 hobbs /usr/libexec/gdm-x-session[2294]: (WW) NVIDIA(0): WAIT (2-S, 17, 0x0943, 0x000034d8, 0x00007f64)

Keyboard and mouse lockup (including caps/num lock)

I’ve gone back to the 470 driver as I think it happens less frequently with it. I’ve seen posts saying that this doesn’t happen with the 460 driver

I don’t have reproduction steps but Firefox can often trigger the problem. At times Firefox will also trigger an almost lock up (GUI is locked up) but keyboard can still respond and if I go to a terminal, eg and do a killall firefox I can sometimes get the GUI to respond again but sometimes it’s a full reboot required.

I updated my Ubuntu a few days ago and looks like with an update to the 470.182 driver I’m now having to reboot many times a day again due to lockups :-(

Same boat still. Cant use my external monitors setup due to this. This issue should be getting more traction.

Well too bad that Nvidia doesn’t care at all… it’s a major issue that’s been around since I’m using an optimus laptop on linux (3 years and maybe even more I don’t know)

Honestly just the fact that the support doesn’t respond to Linux user is scandalous, I’ve paid the same amount for my GPU and YOU SUPPORT LINUX. Now I want at least a stable and working product !!!


And by the way, Xorg is going away, maybe you should finally consider to support a little Wayland.

Anyway, Optimus laptops are lottery with the poor driver we have.

Hi All,
Would be great if anyone can share reliable repro steps to reproduce issue and please add Option "ModeDebug" "True" to the device section of xorg.conf and capture the log again from repro state for triage purpose.