Display Freezing issue with two separate Linux OS's

Hello! This has happened with two different os’s. First with Pop!_OS. I tried everything to fix it and worked with System76 Forum to get it to stop freezing. I gave up after a month and decided to switch to Mint. I thought it was an error with the os. It is now doing it with Mint. I don’t know what is going on. I will be forever grateful if someone can figure this out.

nvidia-bug-report.log.gz (327.0 KB)

Kernel: 5.15.0-70-generic x86_64 bits: 64 compiler: gcc v: 11.3.0 Desktop: Cinnamon 5.6.8
tk: GTK 3.24.33 wm: muffin dm: LightDM Distro: Linux Mint 21.1 Vera base: Ubuntu 22.04 jammy
Type: Desktop Mobo: NZXT model: N7 B550
UEFI: American Megatrends LLC. v: P1.80 date: 10/19/2022
Info: 6-core model: AMD Ryzen 5 3600X bits: 64 type: MT MCP arch: Zen 2 rev: 0 cache:
L1: 384 KiB L2: 3 MiB L3: 32 MiB
Speed (MHz): avg: 2417 high: 3727 min/max: 2200/3800 boost: enabled cores: 1: 2196 2: 2195
3: 2208 4: 2066 5: 3727 6: 2084 7: 2189 8: 2195 9: 2196 10: 1967 11: 3593 12: 2394
bogomips: 91037
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Device-1: NVIDIA TU104 [GeForce RTX 2070 SUPER] vendor: Gigabyte driver: nvidia v: 525.105.17
pcie: speed: 2.5 GT/s lanes: 16 ports: active: none off: DP-2,DP-3 empty: DP-1,HDMI-A-1
bus-ID: 06:00.0 chip-ID: 10de:1e84
Device-2: Logitech C922 Pro Stream Webcam type: USB driver: snd-usb-audio,uvcvideo
bus-ID: 1-3.3:5 chip-ID: 046d:085c
Display: x11 server: X.Org v: driver: X: loaded: nvidia
unloaded: fbdev,modesetting,nouveau,vesa gpu: nvidia display-ID: :0 screens: 1
Screen-1: 0 s-res: 3840x1080 s-dpi: 81
Monitor-1: DP-2 pos: primary,right res: 1920x1080 dpi: 82 diag: 686mm (27")
Monitor-2: DP-5 pos: primary,left res: 1920x1080 dpi: 96 diag: 584mm (23")
OpenGL: renderer: NVIDIA GeForce RTX 2070 SUPER/PCIe/SSE2 v: 4.6.0 NVIDIA 525.105.17
direct render: Yes
Device-1: NVIDIA TU104 HD Audio vendor: Gigabyte driver: snd_hda_intel v: kernel pcie:
speed: 8 GT/s lanes: 16 bus-ID: 06:00.1 chip-ID: 10de:10f8
Device-2: AMD Starship/Matisse HD Audio vendor: ASRock driver: snd_hda_intel v: kernel pcie:
speed: 16 GT/s lanes: 16 bus-ID: 08:00.4 chip-ID: 1022:1487
Device-3: Logitech C922 Pro Stream Webcam type: USB driver: snd-usb-audio,uvcvideo
bus-ID: 1-3.3:5 chip-ID: 046d:085c
Device-4: Corsair VOID ELITE USB Gaming Headset type: USB
driver: hid-generic,snd-usb-audio,usbhid bus-ID: 5-4:3 chip-ID: 1b1c:0a56
Sound Server-1: ALSA v: k5.15.0-70-generic running: yes
Sound Server-2: PulseAudio v: 15.99.1 running: yes
Sound Server-3: PipeWire v: 0.3.48 running: yes
Device-1: Realtek RTL8125 2.5GbE vendor: ASRock driver: r8169 v: kernel pcie: speed: 5 GT/s
lanes: 1 port: f000 bus-ID: 04:00.0 chip-ID: 10ec:8125
IF: enp4s0 state: down
Device-2: Intel Wi-Fi 6 AX210/AX211/AX411 160MHz driver: iwlwifi v: kernel pcie: speed: 5 GT/s
lanes: 1 bus-ID: 05:00.0 chip-ID: 8086:2725
Local Storage: total: 3.67 TiB used: 88.94 GiB (2.4%)
ID-1: /dev/nvme0n1 vendor: Western Digital model: WD BLACK SN770 2TB size: 1.82 TiB
speed: 63.2 Gb/s lanes: 4 temp: 24.9 C
ID-2: /dev/sda type: USB vendor: PNY model: USB 2.0 FD size: 29.75 GiB
ID-3: /dev/sdb vendor: Western Digital model: WD20EZRZ-00Z5HB0 size: 1.82 TiB speed: 6.0 Gb/s
ID-1: / size: 1.79 TiB used: 44.45 GiB (2.4%) fs: ext4 dev: /dev/nvme0n1p2
ID-2: /boot/efi size: 511 MiB used: 6.1 MiB (1.2%) fs: vfat dev: /dev/nvme0n1p1
ID-1: swap-1 type: file size: 2 GiB used: 0 KiB (0.0%) priority: -2 file: /swapfile
System Temperatures: cpu: N/A mobo: N/A gpu: nvidia temp: 40 C
Fan Speeds (RPM): N/A gpu: nvidia fan: 0%
Processes: 378 Uptime: 36m Memory: 31.28 GiB used: 3.11 GiB (10.0%) Init: systemd v: 249
runlevel: 5 Compilers: gcc: 11.3.0 alt: 11/12 Client: Cinnamon v: 5.6.8 inxi: 3.3.13

There are no error messages which would explain the freezes so I guess your notebook is broken. Rather send it in for repair or have it replaced, if still under warranty.

It’s a desktop. I just took everything apart and put it back together. Hopefully I can figure this out. I appreciate your assistance. Thank you!

Sorry, I just read “System76” and thought it was a notebook.
Since it’s a desktop, I guess you’ll have to take it apart and check every component.