Display issues with GeForce GT 1030 2G on Ubuntu 22.04

Hello! I originally posted this in the wrong forum, but since this is a more technical forum, I’ll just rewrite my findings.

I recently built a media center build and needed to get a video card since my processor does not have onboard graphics. I picked an older model since my usecase doesn’t include games, so I didn’t really need anything too powerful.

I tried installing the latest driver available in the Ubuntu PPA drivers (which I believe is 535) and it did not give me a display when booting to the encrypted volume passphrase screen. I tried manually downloading the most recent driver from the NVidia site and installing it manually (despite the warnings about “unwanted side-effects”) and still, no video or password prompt. I dropped to a recovery shell and installed the 390 drivers according to a tutorial on my specific video card, and while this time I got video for the password prompt, once I unlocked the operating system drive, I proceeded, again, to get no video. I attempted a different monitor to see if it was the monitor not able to handle the resolution output and still no dice. I tried altering the display resolution with xrandr to the mid-range and lowest setting and still, no luck.

With that I’m out of ideas on how to get the nvidia drivers to work. I have since switched to XOrg over Wayland for the Nouveau driver, which seemed to have stopped the Nouveau flickering at least, but I’m very curious how to solve this problem in particular, as I do want to play with the Cuda cores available on the card. Attached is the bug report. Thank you!

nvidia-bug-report.log.gz (141.4 KB)

I just got a chance to review the logs and compared it to the boot sequence for the Nouveau driver, and it looks like the problem appears to be that when I’m using the Nvidia driver, it defaults to display port HDMI-0-- but that’s the onboard video port on the motherboard, which doesn’t work because the video card comes out of port HDMI-1. My guess is I’ll have to plug in to the onboard video port to see if I get video. Which is confusing because when the BIOS boots, the video comes out of the video card, not the onboard video. Perhaps the most recent drivers fixed this issue and makes the output come out of the onboard video port, which is why the most recent drivers displayed a BIOS but then didn’t display anything once the password prompt came up for the encrypted disks? I’m not sure. When I get a chance to test my findings I’ll come back with updates.

So it turns out the issue was the refresh rate after all! My target is a television, and I discovered the Nouveau driver prefers 30hz refresh rate. I set my refresh rate with xrandr to 29.97 and the video displays! Huzzah!

I hope this is helpful for anyone else.

edit: This is in combination with the 390 drivers so that you get a password prompt. I don’t particularly care to figure out the newer drivers, so I’m sitting with this stable one for my use case.

You might be wondering about the TV preferring 30hz. I discovered this is because I had the PC plugged into an HDMI switch, which handles up to 4 HDMI inputs and has 1 HDMI output. This device was limiting the signal to 30hz. Plugging the PC directly into the TV worked as normally, and nvidia-auto-select detected my device properly.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.