Display Port(DP)

I am on Jetpack5.1( from latest sdk manager). I am using a DP->HMI converter and it works on x11 only, but not when I disable the ubuntu desktop( sudo systemctl set-default multi-user.target) . I’ve tried modprobe nvidia-drm modeset=1 and all I see is no signal on my display, plus there are no framebuffers.

And no matter what I do I always get the following error when I run my Qt6 application. What is strange here is that the display shows the NVIDIA logo on boot, so that means no DP->HDMI conversion issues and X11 works too, but disabling the desktop causes nothing to work… egl, kms, vulkan, weston, nothing…

resetSurface: Unable to connect stream
EGL Error : Could not create the egl surface: error = 0x321c

All works fine on Xavier.

Also, the NVIDIA demo below doesn’t work. I got no frame buffers. DISPLAY=:0 xrandr has no displays.


What am I missing?

Your help is greatly appreciated.

Bummer… no help… there have to be other folks having this issue.

Since there is no fbcon supported on Orin AGX, you can only make it work with X11 enabled.

@WayneWWW thank you. Limits Orin in so many ways, I hope that will be fixed soon.

Wayland works by the way, but it is silly slow. Any advice to speed it up?

Could you file a new topic and share us the steps how you enabled Wayland and what did you see on the screen? Thanks.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.