Display port will not respond to drivers whatsoever on Linux


I own a laptop ASUS G14 with AMD Ryzen 9 5900hs and nVIDIA RTX 3060 Mobile / Max-Q

I run Ubuntu 22.04 LTS.

I have a setup with 3 Monitors. One is an embedded monitor with the laptop, and two are standalone 27-inch and 21-inch monitors on HDMI.

On Linux, when I connect one of the monitors to the laptop’s HDMI port it will work fine and two displays will show up (the laptop’s integrated and the external).

However, if I use my display port interface (USB-C display port connected to the laptop’s display port usb C), none of the monitors will work with the Nvidia drivers on Linux.

On Windows, everything works well out of the box with the Display Port attachment.

I tried both Wayland and XORG

I tried everything on stackoverflow and around here on the forums with no success. I tried all driver packages from 470 up to 530 / meta package drivers / server / open / proprietary, manually installed, GUI, nothing seems to make this work.

Ask me what other logs to paste here. For now, check these?

 sudo lshw -C display
       description: VGA compatible controller
       product: GA106M [GeForce RTX 3060 Mobile / Max-Q]
       vendor: NVIDIA Corporation
       physical id: 0
       bus info: pci@0000:01:00.0
       logical name: /dev/fb0
       version: a1
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress vga_controller cap_list fb
       configuration: depth=32 latency=0 mode=1920x1080 visual=truecolor xres=1920 yres=1080
       resources: iomemory:fc0-fbf iomemory:fe0-fdf memory:fb000000-fbffffff memory:fc00000000-fdffffffff memory:fe00000000-fe01ffffff ioport:e000(size=128) memory:fc000000-fc07ffff
       description: VGA compatible controller
       product: Cezanne
       vendor: Advanced Micro Devices, Inc. [AMD/ATI]
       physical id: 0
       bus info: pci@0000:04:00.0
       logical name: /dev/fb0
       version: c4
       width: 64 bits
       clock: 33MHz
       capabilities: pm pciexpress msi msix vga_controller bus_master cap_list fb
       configuration: depth=32 driver=amdgpu latency=0 resolution=1920,1080
       resources: iomemory:fe0-fdf iomemory:fe0-fdf irq:44 memory:fe10000000-fe1fffffff memory:fe20000000-fe201fffff ioport:d000(size=256) memory:fc500000-fc57ffff


find /usr/lib/modules -name nvidia.ko -exec modinfo {} \;
filename:       /usr/lib/modules/5.19.0-41-generic/updates/dkms/nvidia.ko
firmware:       nvidia/470.182.03/gsp.bin
alias:          char-major-195-*
version:        470.182.03
supported:      external
license:        NVIDIA
srcversion:     F2CDE7AABDDB6D13598C5B2
alias:          pci:v000010DEd*sv*sd*bc03sc02i00*
alias:          pci:v000010DEd*sv*sd*bc03sc00i00*
depends:        drm
retpoline:      Y
name:           nvidia
vermagic:       5.19.0-41-generic SMP preempt mod_unload modversions 
sig_id:         PKCS#7
signer:         G14 Secure Boot Module Signature key
sig_key:        12:1B:1D:53:67:8F:97:1F:3E:D2:28:22:63:87:62:6E:AF:70:CD:6B
sig_hashalgo:   sha512
signature:      63:EE:25:AF:AE:61:8A:D8:C3:EC:48:39:77:41:56:17:BA:91:77:E2:
parm:           NvSwitchRegDwords:NvSwitch regkey (charp)
parm:           NvSwitchBlacklist:NvSwitchBlacklist=uuid[,uuid...] (charp)
parm:           NVreg_ResmanDebugLevel:int
parm:           NVreg_RmLogonRC:int
parm:           NVreg_ModifyDeviceFiles:int
parm:           NVreg_DeviceFileUID:int
parm:           NVreg_DeviceFileGID:int
parm:           NVreg_DeviceFileMode:int
parm:           NVreg_InitializeSystemMemoryAllocations:int
parm:           NVreg_UsePageAttributeTable:int
parm:           NVreg_RegisterForACPIEvents:int
parm:           NVreg_EnablePCIeGen3:int
parm:           NVreg_EnableMSI:int
parm:           NVreg_TCEBypassMode:int
parm:           NVreg_EnableStreamMemOPs:int
parm:           NVreg_RestrictProfilingToAdminUsers:int
parm:           NVreg_PreserveVideoMemoryAllocations:int
parm:           NVreg_EnableS0ixPowerManagement:int
parm:           NVreg_S0ixPowerManagementVideoMemoryThreshold:int
parm:           NVreg_DynamicPowerManagement:int
parm:           NVreg_DynamicPowerManagementVideoMemoryThreshold:int
parm:           NVreg_EnableGpuFirmware:int
parm:           NVreg_EnableUserNUMAManagement:int
parm:           NVreg_MemoryPoolSize:int
parm:           NVreg_KMallocHeapMaxSize:int
parm:           NVreg_VMallocHeapMaxSize:int
parm:           NVreg_IgnoreMMIOCheck:int
parm:           NVreg_NvLinkDisable:int
parm:           NVreg_EnablePCIERelaxedOrderingMode:int
parm:           NVreg_RegisterPCIDriver:int
parm:           NVreg_RegistryDwords:charp
parm:           NVreg_RegistryDwordsPerDevice:charp
parm:           NVreg_RmMsg:charp
parm:           NVreg_GpuBlacklist:charp
parm:           NVreg_TemporaryFilePath:charp
parm:           NVreg_ExcludedGpus:charp
parm:           rm_firmware_active:charp


xrandr --query
Screen 0: minimum 320 x 200, current 1920 x 1080, maximum 16384 x 16384
eDP connected (normal left inverted right x axis y axis)
   1920x1080    144.00 + 120.00    96.00    72.00    60.00    50.01    48.00    60.00  
   1680x1050    144.00  
   1280x1024    144.00  
   1440x900     144.00  
   1280x800     144.00  
   1280x720     144.00  
   1024x768     144.00  
   800x600      144.00  
   640x480      144.00  
HDMI-A-0 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 598mm x 336mm
   1920x1080     60.00 +  74.97*   72.01    60.01    50.03    48.02    50.00    59.94  
   1680x1050     59.88  
   1280x1024     75.02    60.02  
   1440x900      59.90  
   1280x800      60.00  
   1152x864      75.00  
   1280x720      60.00    50.00    59.94  
   1024x768      75.03    70.07    60.00  
   800x600       72.19    75.00    60.32  
   720x576       50.00  
   720x480       60.00    59.94  
   640x480       75.00    72.81    60.00    59.94  
   720x400       70.08  

470.182.03 is a legacy driver, you need a newer driver.

Kind of a newbie here, but I have a similar setup with an A4000 on Ubuntu 23.04. I’ve only been able to get my computer into a workable condition by using hybrid graphics mode and Xorg on the 530.41.03 driver. Also getting some segmentation faults in the logs as per my post here:

I am guessing that my integrated Intel card is stepping in to make things usable? I’ve tried with the latest update to 5.25, but that is completely broken. Adding to this thread to support the idea that USB-C display port external monitor may indeed be a problem. Happy to provide more info if someone can guide me on how to get it.

Ok, for anyone struggling with this, I think it’s a kernel compatibility problem related to the ROG laptop I own.

I was on Ubuntu 22.04 and I made several changes to the kernel to make other things work (Bluetooth, WiFi etc) and I think I messed something up.

Should you have the same issue, do what I did: Install the latest Ubuntu 23.04. It has the new kernel 6.2 and it should support the ROG G14 out of the box.

You might encounter black screen at boot because the integrated video is still somehow broken (From AMD in my case). To fix this edit the GRUB setup and run with `nomodeset’ as illustrated here


After this, you can install your driver (525 seems stable here)

I tried a bunch of things and there are still some glitches. Don’t touch fractional scaling in displays.

In conclusion, I think this issue is related to my laptop being too bleeding edge for open-source software (ubuntu 22.04), but the new kernels caught up to all of these issues. I guess this is the pay you pay for using gaming laptops with linux distros