Display Problem

Please provide the following info (tick the boxes after creating this topic):
Software Version
[*] DRIVE OS 6.0.6
DRIVE OS 6.0.5
DRIVE OS 6.0.4 (rev. 1)

Target Operating System
[*] Linux

Hardware Platform
DRIVE AGX Orin Developer Kit (940-63710-0010-D00)
DRIVE AGX Orin Developer Kit (940-63710-0010-C00)
[*] DRIVE AGX Orin Developer Kit (not sure its number)

SDK Manager Version
[*] other

Host Machine Version
[*] native Ubuntu Linux 20.04 Host installed with SDK Manager
native Ubuntu Linux 20.04 Host installed with DRIVE OS Docker Containers
native Ubuntu Linux 18.04 Host installed with DRIVE OS Docker Containers


I have connected the ORIN devkit with a screen monitor through a displayport cable. There is no display, meaning that the screen does not receive signal from neither HDMI or DP. I have tried both DP to HDMI and DP to DP cables.
I have successfully installed SDK manager on Linux host PC, and successfully flashed on NVIDIA ORIN devkit. Minicom has been configured, successfully and we can ping on internet sites, and we have run some samples successfully.
I am attaching the flashing logs here:
SDKM_logs_DRIVE_OS_6.0.6_SDK_Linux_for_DRIVE_AGX_Orin_DevKits_2023-05-23_15-38-52.zip (2.6 MB)

Dear @Thanos_Alexopoulos,
Please check if DRIVE AGX no display output issue helps?

Different monitors have been tested, but none worked. Regarding " Finalize DRIVE AGX Orin System Setup" instructions, one question that arises has to do with the first note:

EULA has been accepted only through SDK manager, but instructions state that EULA Must be accepted on the ORIN devkit, or the DP display wont work. Since I have no access to the devkit UI, is it possible to accept EULA through minicom? Or maybe is there a way to make sure (through minicom) that EULA has been accepted or not?

Dear @Thanos_Alexopoulos,
During first boot after flashing, you are expected to see EULA info in serial console via minicom. Please check and let us know if you see any issue

I have not been automatically prompted to accept the EULA during the first boot, after flashing successfully. Maybe Minicom is not configured correctly? (I have access to the ORIN devkit though). I am attaching the configuration we are using:

By looking at the devkit instructions:

we followed the steps as described above, during step 6, we get this when we use “minicom -s”

but we are not prompted to accept EULA. Is there something wrong with the serial port settings?

It appears that your configuration is correct. To further troubleshoot the issue, I recommend referring to Software Setup on the Linux Host and ensuring that you can see messages on ttyACM0 when power cycling the devkit.

We have followed the instructions but again our display monitor does not receive any signal, even though the ttyS2 seems to have the console enabled.

When deploying "sudo dmesg | grep -i tty* " command as its written in the instructions we receive the following output.

Also the whitened out line at the bottom of the prompt reads “Offline”. Is this relevant?
Connecting USB 2.0 port on ORIN devkit with the host linux pc does not let us write any command on minicom. Neither the LEFT USB 3.2 Type-C allows communication with the devkit. (We have not used the RIGHT USB 3.2 Type-C, as it is clearly stated in the instructions). Can you confirm which is the port we should use?

The port that allows us to communicate with the devkit is the DEBUG USB Micro-C. Neither this time that we have reconfigured minicom have we been prompted to accept the EULA aggreement.

Something that is also interesting, is that the /home/nvidia/ directory is empty indicating that no user setup has been deployed yet (“nvidia” is the username we have selected during the installation/flashing using sdkmanager).

Furthermore, the instructions to which you are referring to, state that for P3710, we should use ttyACM0 for NVIDIA DRIVE Orin™ X1. The ttyACM0 does not appear in the /dev directory of the ORIN devkit device (see below).

Instead, when we connect using ttyACM0, minicom prints out connection as ttyS2 (see first screenshot).

Please let me know if it is possible to have a short call so that we can short this out, or if there is any other action/command we can do to verify the system state.

Dear @Thanos_Alexopoulos,
Please check below and confirm if you get EULA notice.

  1. Restart host PC
  2. Connect to Tegra A console using minicom from host and reboot the target( you may use poweroff/poweron from aurix console or check hard rebooting of target)

If the EULA notice does not come, is it ok check reflashing and careful about EULA notice in first boot?

Hi @SivaRamaKrishnaNV and thanks for the quick reply.

I have performed restart of Linux host, connecting to Tegra A using minicom (device ttyACM0) and “rebooted” Orin using the ON/OFF switch located at the back, next to the power cable. Still no EULA notice.

How can I perform “aurix console” poweroff/on or what is the “hard rebooting”? I am guessing what I did (on/off switch) should be the “hard reboot”.

I can try to reflash, shall I try the same DRIVE OS 6.0.6, which I already installed, or maybe the previous, 6.0.5? What would you recommend?

Dear @Thanos_Alexopoulos ,
How can I perform “aurix console” poweroff/on or

You can connect to Aurix console on /dev/ttyACM1 and run poweroff and poweron.

what is the “hard rebooting”? I am guessing what I did (on/off switch) should be the “hard reboot”.


Please check flashing DRIVE OS 6.0.6 with Force wipe of user logins in persistent partition option enabled (Install DRIVE OS with SDK Manager | NVIDIA Docs)

Hello again,

We have performed a successful reflash.
Our display is alive, and we have access to the file system of ORIN devkit.
We have never been prompted to accept any EULA.
Note: /home/nvidia direcotry (nvidia=user) is still empty, we don’t know if this is ok or not. ORIN devkit can perform various tasks, such as browsing the internet, explore directories.
If you have any further comments/warnings/recommendations, please let us know.

Thats ok. It is empty.
Just want to confirm, If you lost display after using target few days or you got it first time now?

Hello again,

This was the first time we got an alive display :)

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.