Display to Huawei VR Glasses

Have you tried the suggestion from @Honey_Patouceul ?

Yes, I tried them with no more success then changing the underscan settings directly. In one particular configuration one eye worked properly, but not the second one, but when I tried to change back to those exact settings it didn’t do the same thing.

These would be my last weird advises, just in case you’re out of ideas and have 2 minutes to spend. You may try enabling FullCompositionPipeline and TripleBuffer in Xorg.conf, or try to play with compiz settings if using it. Also try boosting clocks.

I also want to confirm:
Are the only two modes that the VR glasses supports 70 Hz and 90 Hz ones? Are there any other modes that we can try out, or only those two here?

Also more test to be conducted:

  1. Run the previous steps to enable a solid blue background.
  2. While the blue background is showing:
  • Do “echo 1 > /sys/class/graphics/fbX/device/crc_checksum_latched”
  • Do “cat /sys/class/graphics/fbX/device/crc_checksum_latched” multiple times over the span of ~30 seconds, and record the CRC values for us.

Hello @ben.mcdonnell

Any feedback for the last comment?