DisplayPort bandwidth Problem

I have single T1000 card on Ubuntu system and want to start four separate 4K screens at 60 Hz each. I use nvidia-settings for configuring X layout. By default nvidia-settings put all monitors into one screen and that mode work as supposed - I can specify 3840x2160@60Hz for each monitor and after saving configuration and restarting X system all is set as supposed (similar picture for each monitor):

But then I tried to create 4 separate screens with same 3840x2160@60Hz parameters X not started with following complain:

20161 [  8597.616] (II) NVIDIA(0): Screen initialization complete
20162 [  8597.618] (II) NVIDIA(1): kernel module enabled successfully
20163 [  8597.618] (II) NVIDIA(1): GPU initialized
20164 [  8597.620] (==) NVIDIA(1): Using 8388608 bytes for software rendering cache
20165 [  8597.650] (II) NVIDIA(1): Setting mode "DP-0:3840x2160_60+0+0{AllowGSYNC=Off}"
20166 [  8597.685] (WW) NVIDIA(1): Failed to set the display configuration
20167 [  8597.685] (WW) NVIDIA(1):  - Setting a mode on display 0 failed: There was insufficient
20168 [  8597.685] (WW) NVIDIA(1):     available DisplayPort bandwidth
20169 [  8597.685] (EE)
20170 Fatal server error:
20171 [  8597.685] (EE) AddScreen/ScreenInit failed for driver 1
20172 [  8597.685] (EE)
20173 [  8597.685] (EE)

It failed on initialization of second screen.
Specification of T1000 says it support 4x 4K @120Hz
I can’t understood why this problem is happened.

My four monitors currently are plugs (all the same) with following parameters :

      EDID Name             : XMD Mi TV
      Minimum HorizSync     : 15.000 kHz
      Maximum HorizSync     : 140.000 kHz
      Minimum VertRefresh   : 49 Hz
      Maximum VertRefresh   : 80 Hz
      Maximum PixelClock    : 600.000 MHz
      Maximum Width         : 4096 pixels
      Maximum Height        : 2160 pixels
      Preferred Width       : 1920 pixels
      Preferred Height      : 1080 pixels
      Preferred VertRefresh : 60 Hz
      Physical Width        : 600 mm
      Physical Height       : 340 mm

(I tried different configurations with 2 and 3 cards, but returned to testing configuration with single card, hope someone can recognize what is the problem here).
Need to state that use of 1920x1080 resolutions or 30Hz refresh rates allow X system to start. The problem appeared when 4K@60Hz is used.

nvidia-bug-report.log.gz (1.2 MB)

Different error can be found in log file when I try to start 8 4K screens with 2 video cards. Configuration prepared with nvidia-settings tool, frequency was left to auto but same problem exist when specified 60Hz explicitly.

[253677.941] (II) NVIDIA(7): kernel module enabled successfully
[253677.941] (II) NVIDIA(7): GPU initialized
[253677.943] (==) NVIDIA(7): Using 8388608 bytes for software rendering cache
[253677.959] (II) NVIDIA(7): Setting mode "DP-6:3840x2160+0+0"
[253677.983] (WW) NVIDIA(7): Failed to set the display configuration
[253677.983] (WW) NVIDIA(7):  - Setting a mode on head 3 failed: Invalid surface parameters
[253677.983] (WW) NVIDIA(7):     were specified
[253677.983] (EE)
Fatal server error:
[253677.983] (EE) AddScreen/ScreenInit failed for driver 7
[253677.983] (EE)
[253677.983] (EE)

Updated bug report log attached if someone is willing to look into it.
nvidia-bug-report.log.gz (1.2 MB)

Installed driver 470 and this problem is gone. I can create separate 60Hz screens now. All drivers since 470 not work properly in this respect. Unfortunately 4K playback for each channel using hardware decoding a bit laggy with 470… Actually it still buggy with 535 so it’s hard to select something usable for nVidia in Linux…