Displays overlap on boot (GTX 970, NVidia Driver 415.27, Linux Mint 19.1 64-bit)

When I start my computer, the screens always have some overlap, which results in the screen sliding over some when I move my mouse to the right side of the screen. To fix it, I have to open NVidia X Server Settings, change the underscan for my second screen, apply changes to fix the issue, then I can switch the underscan value back to what it needs to be. I have to do this every time I start my computer, and it is a major nuisance. In addition, when I run Minecraft, the settings reset to do almost the same thing as when the computer was first booted, the difference being that this time the “panning” option for both displays is set wider than the displays are in the display settings, so the displays pan individually instead of sliding at the same time when I move my mouse to the edge of the screen.
System Details:
Linux Mint 19.1 MATE 64-bit
GTX 970
NVidia Driver 390.77
Edit: nvidia bug report log (generated before doing the temp fix):
https://www.dropbox.com/s/yyihn01miz1oub7/nvidia-bug-report.log.gz?dl=0
Edit 2: I have updated my NVidia Driver to version 415.27 and the issue persists
Screenshots:
When first booted(before fix):
https://i.imgur.com/RjMYXRe.png
After the fix mentioned above:
https://i.imgur.com/WwSd20X.png
After running Minecraft:
https://i.imgur.com/budRBtw.png
If I can provide any more details to try to get this solved, let me know.

Please check if this helps:
https://devtalk.nvidia.com/default/topic/1046618/linux/xorg-mirroring-with-disabled-panning/post/5311263/#5311263
Just ignore the Gnome/GDM specific stuff.

Ok, tried that. Specifically, what I did from that post was:
1.) backup and remove /etc/X11/xorg.conf
2.) check for ~/.config/monitors.xml, and it doesn’t exist
3.) reboot
4.) Make sure my displays are arranged correctly in Displays

It -almost- worked, but the system’s display manager can’t apply underscan, so the only option was to go into NVidia X Server Settings, set the underscan for the second screen, and save to /etc/X11/xorg.conf (which created a new file since I moved the old one while following the instructions). After reboot, the issue was back, with the same behavior as before.

My newly generated xorg.conf:
https://paste.ubuntu.com/p/PgwRDgkjwc/

Is it possible to enable just scan on the TV?

Check this for MATE specific settings:
https://unix.stackexchange.com/questions/310301/prevent-mate-display-settings-override-nvidia-settings

No, this is an older flatscreen TV that doesn’t have the option to just scan.

Ok, tried that. Copying the steps here for easy reading:

  1. Login into Mate
  2. Once logged launch nvidia-settings
  3. Configure the displays and Apply
  4. Now launch mate-display-properties and you'll see that now is set to the same configuration of nvidia-settings.
  5. Don't touch anything and click Apply.

After Step 5, the issue shows back up. So this didn’t solve my issue, but it does seem to point to Mate settings overriding NVidia settings as the reason the issue occurs. It may be worth noting that mate-display-properties still shows the second screen at its original resolution, 1280x720, and not the underscan-adjusted resolution shown in NVidia X Server Settings, 1210x680.

Yes, it’s a general problem when you set the display config using xrandr or nvidia metamodes on one side and run a DE with integrated monitor management on the other side. This results in the xserver getting two different config sets and blends them into one with odd effects like panning.
Though I still wonder why there’s no ~/.config/monitors.xml in your setup. I’m not familiar with MATE, though.