Distortion in output stream

@fanzh while trying ffplay rtsp://localhost:8660/ds-test
i am getting this error:

(base) [appusr@wk-10662 ~]$ ffplay rtsp://localhost:8660/ds-test
ffplay version 4.2.8 Copyright (c) 2003-2022 the FFmpeg developers
built with gcc 8 (GCC)
configuration: --prefix=/usr --bindir=/usr/bin --datadir=/usr/share/ffmpeg --docdir=/usr/share/doc/ffmpeg --incdir=/usr/include/ffmpeg --libdir=/usr/lib64 --mandir=/usr/share/man --arch=x86_64 --optflags=‘-O2 -g -pipe -Wall -Werror=format-security -Wp,-D_FORTIFY_SOURCE=2 -Wp,-D_GLIBCXX_ASSERTIONS -fexceptions -fstack-protector-strong -grecord-gcc-switches -specs=/usr/lib/rpm/redhat/redhat-hardened-cc1 -specs=/usr/lib/rpm/redhat/redhat-annobin-cc1 -m64 -mtune=generic -fasynchronous-unwind-tables -fstack-clash-protection -fcf-protection’ --extra-ldflags=‘-Wl,-z,relro -Wl,-z,now -specs=/usr/lib/rpm/redhat/redhat-hardened-ld ’ --extra-cflags=’ ’ --enable-libopencore-amrnb --enable-libopencore-amrwb --enable-libvo-amrwbenc --enable-version3 --enable-bzlib --disable-crystalhd --enable-fontconfig --enable-frei0r --enable-gcrypt --enable-gnutls --enable-ladspa --enable-libaom --enable-libdav1d --enable-libass --enable-libbluray --enable-libcdio --enable-libdrm --enable-libjack --enable-libfreetype --enable-libfribidi --enable-libgsm --enable-libmp3lame --enable-nvenc --enable-openal --enable-opencl --enable-opengl --enable-libopenjpeg --enable-libopus --enable-libpulse --enable-librsvg --enable-libsrt --enable-libsoxr --enable-libspeex --enable-libssh --enable-libtheora --enable-libvorbis --enable-libv4l2 --enable-libvidstab --enable-libvmaf --enable-version3 --enable-vapoursynth --enable-libvpx --enable-libx264 --enable-libx265 --enable-libxvid --enable-libzimg --enable-libzvbi --enable-avfilter --enable-avresample --enable-libmodplug --enable-postproc --enable-pthreads --disable-static --enable-shared --enable-gpl --disable-debug --disable-stripping --shlibdir=/usr/lib64 --enable-libmfx --enable-runtime-cpudetect
libavutil 56. 31.100 / 56. 31.100
libavcodec 58. 54.100 / 58. 54.100
libavformat 58. 29.100 / 58. 29.100
libavdevice 58. 8.100 / 58. 8.100
libavfilter 7. 57.100 / 7. 57.100
libavresample 4. 0. 0 / 4. 0. 0
libswscale 5. 5.100 / 5. 5.100
libswresample 3. 5.100 / 3. 5.100
libpostproc 55. 5.100 / 55. 5.100
X Error of failed request: GLXBadDrawable
Major opcode of failed request: 146 (GLX)
Minor opcode of failed request: 29 (X_GLXGetDrawableAttributes)
Serial number of failed request: 95
Current serial number in output stream: 95

why did you use “localhost:8660”? from the error “X Error of failed request: GLXBadDrawable”, ffplay created display failed.

@fanzh i used localhost because i am trying to play the stream on the same BOX that has deepstream running.
I tried to use the ip instead but got the same error, what could be wrong?

if your box is a headless server, please use ffplay on the machine where your play vlc.

@yingliu we changed that, we are exporting the display from headless server through XTERM
in this case, the terminal can display the output in a seperate window, see screenshot

the machine which i use to play VLC is a windows machine so ffplay isnt installed, is there a windows version of ffplay?
Running ffplay from a remote VNC connection on the deepstream server is giving the below error:

please goggle windows ffplay.


Playing using ffplay on my windows machine still shows distorted images:

Recording using ffmpeg on my windows machine shows similar distorted images:

Running ffplay on the deepstream server (finally was able to run it using a direct VNC connection), shows clear image without distortion:

Pulling my hair out, can this be a network issue? tracing network is going to be painful.

playing on the server is good, playing on the remote machine is bad, it should be network issue, you can do network capturing by Wireshark.

@fanzh i confirm that the issue stands with my own windows machine, playing stream on another windows machine on the same network did not cause any rendering issue.

I am now facing another problem so i opened another thread here
Appreciate your help


Glad to know you fixed it, thanks for the update! If have a new problem, please open a new topic. Thanks

@fanzh appreciate if you help with my new issue here

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.