DLProf installation issue in AGX Xavier

I want to profile my pytorch1.7 / tensorRT code in docker, to check GPU, DLA, TensorCore usage with DLProf. However, the DLProf installation fails.

The installation steps are as in: DLProf User Guide :: NVIDIA Deep Learning Frameworks Documentation
1.
pip install nvidia-pyindex
2.
pip install nvidia-dlprof

But step 2 fails.
By the way, I run my pytorch / tensorRT application in docker, should I install DLProf inside or outside docker?

my CUDA version is 10.2

The error message is:
ERROR: Cannot install nvidia-dlprof==0.15.0, nvidia-dlprof==0.16.0, nvidia-dlprof==0.17.0, nvidia-dlprof==0.18.0, nvidia-dlprof==0.19.0, nvidia-dlprof==1.0.0, nvidia-dlprof==1.1.0 and nvidia-dlprof==1.2.0 because these package versions have conflicting dependencies.

The conflict is caused by:
nvidia-dlprof 1.2.0 depends on nvidia-nsys-cli>=2020.4.1.117
nvidia-dlprof 1.1.0 depends on nvidia-nsys-cli==2021.2.1.58
nvidia-dlprof 1.0.0 depends on nvidia-nsys-cli>=2020.4.1.117
nvidia-dlprof 0.19.0 depends on nvidia-nsys-cli>=2020.4.1.117
nvidia-dlprof 0.18.0 depends on nvidia-nsys-cli>=2020.4.1.117
nvidia-dlprof 0.17.0 depends on nvidia-nsys-cli>=2020.4.1.117
nvidia-dlprof 0.16.0 depends on nvidia-nsys-cli==2020.4.1.117
nvidia-dlprof 0.15.0 depends on nvidia-nsys-cli==2020.4.1.117

To fix this you could try to:

  1. loosen the range of package versions you’ve specified
  2. remove package versions to allow pip attempt to solve the dependency conflict

ERROR: ResolutionImpossible: for help visit User Guide - pip documentation v21.2.dev0

Thanks in advance.

Hi,

There is a preinstalled Nsight System on Jetson.

You can type $ nsys --version for the details.
The version is 2020.5 and should meet your requirement.

Thanks.

Thanks for your reply.

I type nsys --version, and get
NVIDIA Nsight Systems version 2020.5.3.17-0256620

but the
pip install nvidia-dlprof
still show the same error message.

That’s a little bit strange.

Hi,

Sorry for the missing.

Currently, DLProf only supports Ubuntu linux systems with Volta GPU.
It cannot be used on the Jetson which is an L4T system.

Thanks.

Thanks for your reply!
It helps a lot.
I will use nvprof instead.