Do I have a defective unit? New Jetson Nano not booting. Everything works on another unit

This is my first time working with these.
I have two Jetson Nano dev kits, model P3450. They were both brand new and never used.
I was trying to set them up with power from a barrel jack, USB mouse, USB keyboard, a HDMI monitor and a SD card, following the start guide from the link in the box.
On one unit, i was able to progress to linux graphic interface and agreeing to terms and conditions. But the other unit I only see the green power light and fan moving, the mouse does not light up, and the monitor does not turn on.

Do I have a defective unit?
I have tried to apply for RMA through live chat, but they directed me here. Hope I’m in the right place.

I see from the pinned FAQ I should probably get myself a TTL to USB converter and link the unit to a computer to access the boot log, but getting one would take a few days, so I’m making this post in case I’m missing something.


You can flash your jetson nano with sdkmanager from another x86_64 host first.

When I connect the unit i suspect to be defective to my computer, the sdk manager would not recognize anything and displays “no board connected”, neither does it show up on dmesg.

Keeping everything else the same, I tried the one that was okay, and the sdk manager recognized it with no problem.

Is this a defective unit?


If your jetson is not able to boot up, you need to manually put your board into recovery mode so that sdkmanager can detect it…

Did you do that or not?

No, it was not on the guide, I didn’t knew I need to do that, and I didn’t want to break anything.

I connected FC REC and GND for a second and now my sdk manager was able to recognize the board. Now the SDK manager says there’s no release for ubuntu 20.04. I’m going to install ubuntu 18.04 and try again.

Will update, but in the meantime thanks for the help.

I have done according to the SDK manager’s manual setup instructions to connect the pins, power on, then disconnect the pins, but it still tells me it cannot find device in recovery mode.

I have also tried the automatic setup, but it says cannot connect via SSH. I used the username/password “nvidia/nvidia” as that was what I was able to find on google as the default, and “ubuntu/ubuntu”, neither works.

Just in case I also tried doing the automatic setup in recovery mode, which gives the error message default ip not available.


Just one test here. Could you use your other “fine unit” to make sure your steps to enable “recovery mode” is really correct? (This won’t hurt your other units, no need to worry about it)

Also, you don’t need to use SDKmanager gui to tell whether it is in recovery mode or not. Just use command “lsusb” on your x86 host and if the board is really in recovery mode, you shall see “nvidia corp” info on it.

You can paste lsusb for me to confirm too.

I found out i was doing that with the fine unit so i swapped it with the broken one in recovery mode and was able to successfully install ubuntu on that one. everything looks good now, thanks for the help!

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.