do pgi fortran supports cula ?

vs2010+pgi fortran

configure the environment

1.globle setting
select tools>options>project and solutions>pvf directories,configure global exextable,include,and library paths
2.project setting
configuration properties>linker>input. in the additional dependences field ,enter “libcula_pgfortan.lib”
3.runtime path
copy cula.dlland its’s dlls to the working directory

but when i run the program there are errors::like this

SourceFile1.obj : error LNK2019: unresolved external symbol _CULA_INITIALIZE@0 referenced in function MAIN
SourceFile1.obj : error LNK2019: unresolved external symbol _CULA_SGEQRF@20 referenced in function MAIN
SourceFile1.obj : error LNK2019: unresolved external symbol _CULA_SHUTDOWN@0 referenced in function MAIN
SourceFile1.obj : error LNK2019: unresolved external symbol _CULA_GETERRORINFO@0 referenced in function _CHECK_STATUS@4
SourceFile1.obj : error LNK2019: unresolved external symbol _CULA_GETSTATUSSTRING@4 referenced in function _CHECK_STATUS@4

can you help me?

Hi Lyh,

Try the following settings instead:

  1. Linker | General | Additional Library Directories

Put the path to the CULA library directory

  1. Linker | Input | Additional Dependencies

Put the name of the CULA library, i.e., libcula_pgfortran.lib

  1. Debugging | Environment

Add the path to the CULA DLLs to the PATH environment variable.
For example, set this property to PATH=newpath;%PATH%


Hope this helps,
Mat

Thanks for your help
I had done according your suggestions,but it still have errors
1)Linker | General | Additional Library Directories
C:\Program Files\cula\lib

  1. Linker | Input | Additional Dependencies
    libcula_pgfortran.lib

  2. Debugging | Environment(add"C:\Program Files\cula\bin"to the enviromrnt variable which is named"cula_bin_path_32")
    %cula_bin_path_32%

Is there somthing wrong?