I received a brand new Jetson Tx2 developer kit and followed the quick start guide but there are issues. Not sure where to direct my problem.

My power supply brick shows a blue light when I plug it in and the board displays a single red LED CR5. When I press the power button I get two green LEDs at PWR and SOC and an addition red LED at PCIE/SATA CR6. But the USB port is dead and the display does not show any sign of life.



In the meantime I connected a serial port to the target and when it powered up it sent out a significant amount of data on the serial port - too much to include here unless there was a way to upload a 43K log file. Not sure what to look for in the log but I don’t see any glaring errors being reported. Here’s a clip from it:

MMC: no card present
switch to partitions #0, OK
mmc0(part 0) is current device
Scanning mmc 0:1…
Found /boot/extlinux/extlinux.conf
Retrieving file: /boot/extlinux/extlinux.conf
213 bytes read in 70 ms (2.9 KiB/s)
p2771-0000 eMMC boot options
1: primary kernel
Enter choice: 1: primary kernel
Retrieving file: /boot/Image
20280368 bytes read in 534 ms (36.2 MiB/s)
append: root=/dev/mmcblk0p1 rw rootwait console=ttyS0,115200n8 console=tty0 OS=l4t fbcon=map:0 net.ifnames=0 memtype=0 video=tegrafb no_console_suspend=1 earlycon=uart8250,mmio32,0x03100000 nvdumper_reserved=0x2772e0000 gpt tegraid=18.1 .2.0.0 tegra_keep_boot_clocks maxcpus=6 androidboot.serialno=0322417006543 bl_prof_dataptr=0x10000@0x277240000 sdhci_t egra.en_boot_part_access=1 root=/dev/mmcblk0p1 rw rootwait rootfstype=ext4

Flattened Device Tree blob at 92000000

Booting using the fdt blob at 0x92000000
reserving fdt memory region: addr=80000000 size=10000
Using Device Tree in place at 0000000092000000, end 000000009204664f

Starting kernel …

[ 0.000000] Booting Linux on physical CPU 0x100
[ 0.000000] Initializing cgroup subsys cpuset
[ 0.000000] Initializing cgroup subsys cpu
[ 0.000000] Initializing cgroup subsys cpuacct
[ 0.000000] Linux version 4.4.38-tegra (buildbrain@mobile-u64-1279) (gcc version 4.8.5 (GCC) ) #1 SMP PREEMPT Fri J ul 28 09:55:22 PDT 2017
[ 0.000000] Boot CPU: AArch64 Processor [411fd073]


Found that it was hung up on what it considered an invalid HDMI port. I changed out the HDMI monitor and cable and it proceeded to a valid prompt. Still no display, but at least that is progress.

What you are seeing is a fairly common software issue…odds are your Jetson is not DOA and will work correctly with a bit of investigation.

Typically you can post a log on the forum by highlighting the text with a mouse and then clicking on the “code” icon in the upper right (looks like “</>”). You could click the code icon first, then paste into the middle of the tags (useful if it is a large log…seeing the entire boot log from serial console would be useful since “code” has scrollbars and preserves formatting).

You might want to post a copy of “/var/log/Xorg.0.log” from after boot completes, along with describing if there are any cable adapters (or if it is purely HDMI). You can rename a log file with “.txt” suffix, and then attach to an existing post (sorry, no such ability while creating a forum post). To attach a file hover the mouse over the quote mark of the post and note that a paper clip icon will show up…this is the way to attach a file. Eventually it will probably be useful to add this to the ‘Section “Device”’ of “/etc/X11/xorg.conf”, followed by reboot and posting the new log:

Option    "ModeDebug"

You will also want to post the output of:

sudo -s
cat `find /sys -name 'edid'`

For some more information on video debugging see:

I have the platform up and running now and am able to run the samples. It appears that the issue was that I was originally using an HDMI to VGA converter which the platform did not like and so the boot hung up and would not continue. Once I changed to a real HDMI and ran the installation everything worked fine.
I would not have been able to figure this out without first hooking up a serial console to the platform and viewing the boot sequence. I did this by getting a TTL serial to USB cable that I had laying around from Adafruit and hooking it up using this video:

Hope this helps others.

I have the same issues with a monitor connected via a HDMI-to-DVI adapter. My workaround is to connect the monitor only after 20 seconds after power up or reset.