DOCA sample app error

Hi ,

I had installed the BF2 in my server , had flashed the binary using the GUI method , unfortunately facing the below error when application is ran , looks like doca-common package is missing , kindly do let me know , how to fix the same

root@localhost:/opt/mellanox/doca/samples/doca_dma/dma_local_copy# meson build
The Meson build system
Version: 0.61.2
Source dir: /opt/mellanox/doca/samples/doca_dma/dma_local_copy
Build dir: /opt/mellanox/doca/samples/doca_dma/dma_local_copy/build
Build type: native build
Program cat found: YES (/usr/bin/cat)
Project name: DOCA_SAMPLE
Project version: 1.5.1007
C compiler for the host machine: cc (gcc 9.4.0 “cc (Ubuntu 9.4.0-1ubuntu1~20.04.1) 9.4.0”)
C linker for the host machine: cc ld.bfd 2.34
C++ compiler for the host machine: c++ (gcc 9.4.0 “c++ (Ubuntu 9.4.0-1ubuntu1~20.04.1) 9.4.0”)
C++ linker for the host machine: c++ ld.bfd 2.34
Host machine cpu family: aarch64
Host machine cpu: aarch64
Found pkg-config: /usr/bin/pkg-config (0.29.1)
Did not find CMake ‘cmake’
Found CMake: NO
Run-time dependency doca-common found: NO (tried pkgconfig)

meson.build:29:0: ERROR: Dependency “doca-common” not found, tried pkgconfig

A full log can be found at /opt/mellanox/doca/samples/doca_dma/dma_local_copy/build/meson-logs/meson-log.txt

Please refer to 1.1. Meson Complains About Missing Dependencies . I slove the problem with this method. You may try it.

Thanks for suggestion , i had tried the same , but still then facing the same issue , the problem here is the meson is still taking the /usr/bin/pkg-config instead of /opt/mellanox/doca/lib/aarch64-linux-gnu/pkgconfig ,

I had found the solution , cmakes was missing , so i had to install them and set the paths given in the troubleshooting guide as suggested in 1.1. Meson Complains About Missing Dependencies

and also pkg config path was updated after running below command

echo $(pkg-config --variable pc_path pkg-config)${PKG_CONFIG_PATH:+:}${PKG_CONFIG_PATH}