Docker DeepStream 5.0 runs quite slow

Please provide complete information as applicable to your setup.

• Hardware Platform (Jetson / GPU): NVIDIA GPU 1070Ti
• DeepStream Version: 5.0
• Docker: nvcr.io/nvidia/deepstream:5.0-dp-20.04-triton

Current config:

Copyright © 2020 NVIDIA Corporation. All rights reserved.

NVIDIA Corporation and its licensors retain all intellectual property

and proprietary rights in and to this software, related documentation

and any modifications thereto. Any use, reproduction, disclosure or

distribution of this software and related documentation without an express

license agreement from NVIDIA Corporation is strictly prohibited.

[application]
enable-perf-measurement=1
perf-measurement-interval-sec=1

[tiled-display]
enable=1
rows=1
columns=1
width=1280
height=720
gpu-id=0

[source0]
enable=1
#Type - 1=CameraV4L2 2=URI 3=MultiURI
type=4
num-sources=1
uri=rtsp://admin:pass12345@10.10.1.30
gpu-id=0

[streammux]
gpu-id=0
batch-size=1
live-source=1
batched-push-timeout=40000

Set muxer output width and height

width=1920
height=1080

[sink0]
enable=2
#Type - 1=FakeSink 2=EglSink 3=File
type=2
sync=0
source-id=0
gpu-id=0

[osd]
enable=1
gpu-id=0
border-width=3
text-size=15
text-color=1;1;1;1;
text-bg-color=0.3;0.3;0.3;1
font=Arial

[primary-gie]
enable=1
gpu-id=0

Modify as necessary

model-engine-file=/opt/nvidia/deepstream/deepstream-5.0/samples/models/tlt_pretrained_models/peoplenet/resnet34_peoplenet_pruned.etlt
batch-size=1
#Required by the app for OSD, not a plugin property
bbox-border-color0=1;0;0;1
bbox-border-color1=0;1;1;1
bbox-border-color2=0;0;1;1
bbox-border-color3=0;1;0;1
gie-unique-id=1
config-file=config_infer_primary_peoplenet.txt

[sink1]
enable=0
type=3
#1=mp4 2=mkv
container=1
#1=h264 2=h265 3=mpeg4
codec=1
#encoder type 0=Hardware 1=Software
enc-type=0
sync=0
bitrate=2000000
#H264 Profile - 0=Baseline 2=Main 4=High
#H265 Profile - 0=Main 1=Main10
profile=0
output-file=out.mp4
source-id=0

[sink2]
enable=0
#Type - 1=FakeSink 2=EglSink 3=File 4=RTSPStreaming 5=Overlay
type=4
#1=h264 2=h265
codec=1
#encoder type 0=Hardware 1=Software
enc-type=0
sync=0
bitrate=4000000
#H264 Profile - 0=Baseline 2=Main 4=High
#H265 Profile - 0=Main 1=Main10
profile=0

set below properties in case of RTSPStreaming

rtsp-port=8554
udp-port=5400

[tracker]
enable=1
tracker-width=640
tracker-height=384
#ll-lib-file=/opt/nvidia/deepstream/deepstream-5.0/lib/libnvds_mot_iou.so
#ll-lib-file=/opt/nvidia/deepstream/deepstream-5.0/lib/libnvds_nvdcf.so
ll-lib-file=/opt/nvidia/deepstream/deepstream-5.0/lib/libnvds_mot_klt.so
#ll-config-file required for DCF/IOU only
ll-config-file=…/deepstream-app/tracker_config.yml
#ll-config-file=iou_config.txt
gpu-id=0
#enable-batch-process applicable to DCF only
enable-batch-process=1

[tests]
file-loop=0

I can get only 14-15 FPS. I see they don’t use much GPU ~10%. How can I get better performance?
±----------------------------------------------------------------------------+
| NVIDIA-SMI 440.82 Driver Version: 440.82 CUDA Version: 10.2 |
|-------------------------------±---------------------±---------------------+
| Fan Temp Perf Pwr:Usage/Cap| Memory-Usage | GPU-Util Compute M. |
|===============================+======================+======================|
| 0% 61C P2 44W / 180W | 2007MiB / 8116MiB | 10% Default |
±------------------------------±---------------------±---------------------+

+-----------------------------------------------------------------------------+
| Processes:                                                       GPU Memory |
|  GPU       PID   Type   Process name                             Usage      |
|=============================================================================|
|    0      1999      G   /usr/lib/xorg/Xorg                            26MiB |
|    0      2107      G   /usr/bin/gnome-shell                          56MiB |
|    0      2535      G   /usr/lib/xorg/Xorg                           459MiB |
|    0      2702      G   /usr/bin/gnome-shell                         386MiB |
|    0      3185      G   ...uest-channel-token=12337418501827295979    10MiB |
|    0      4120      G   ...uest-channel-token=17880493092199221842   144MiB |
|    0      6740    C+G   ./deepstream-app                             709MiB |
|    0     25494      G   ...equest-channel-token=986078692133692515    76MiB |
+-----------------------------------------------------------------------------+

HI
How about your source resolution?
and please disable batched-push-timeout=40000 and try again.

Hi @amycao,
Thank you for your answer.
I have checked camera, and I set the frame rate of the camera to 30. So now DeepStream can get 30FPS now. But It still use only ~800Mb RAM

What’s your concern of this,

Check this, Part What is the approximate memory utilization for 1080p streams on dGPU?
https://docs.nvidia.com/metropolis/deepstream/dev-guide/index.html#page/DeepStream%20Plugins%20Development%20Guide/deepstream_plugin_faq.html#