Docker not working

my jetson nano from boot is usb but docker ps and other command is not working and result code is =

unexpected fault address 0x24001d4fc28
fatal error: fault
[signal SIGSEGV: segmentation violation code=0x1 addr=0x24001d4fc28 pc=0x5592640944]

goroutine 1 [running, locked to thread]:
runtime.throw({0x559373ecb6?, 0x5593384d60?})
	/usr/lib/go-1.18/src/runtime/panic.go:992 +0x50 fp=0x40005355e0 sp=0x40005355b0 pc=0x5592630840
runtime.sigpanic()
	/usr/lib/go-1.18/src/runtime/signal_unix.go:825 +0x1a4 fp=0x4000535610 sp=0x40005355e0 pc=0x5592646e34
runtime: unexpected return pc for runtime.doInit called from 0x5593cc3580
stack: frame={sp:0x4000535620, fp:0x4000535760} stack=[0x4000516000,0x4000536000)
0x0000004000535520:  0x0000000000000001  0x0000004000535568 
0x0000004000535530:  0x0000005592632890 <runtime.printstring+0x0000000000000050>  0x00000055939d1ba8 
0x0000004000535540:  0x0000000000000001  0x0000000000000001 
0x0000004000535550:  0x0000005592646e1c <runtime.sigpanic+0x000000000000018c>  0x0000004000535568 
0x0000004000535560:  0x0000005592630a20 <runtime.fatalthrow+0x0000000000000040>  0x00000040005355a8 
0x0000004000535570:  0x0000005592630840 <runtime.throw+0x0000000000000050>  0x0000004000535588 
0x0000004000535580:  0x0000000000000001  0x0000005592630a40 <runtime.fatalthrow.func1+0x0000000000000000> 
0x0000004000535590:  0x00000040000021a0  0x0000005592630840 <runtime.throw+0x0000000000000050> 
0x00000040005355a0:  0x00000040005355b0  0x00000040005355d8 
0x00000040005355b0:  0x0000005592646e34 <runtime.sigpanic+0x00000000000001a4>  0x00000040005355c0 
0x00000040005355c0:  0x0000005592630860 <runtime.throw.func1+0x0000000000000000>  0x000000559373ecb6 
0x00000040005355d0:  0x0000000000000005  0x0000004000535568 
0x00000040005355e0:  0x0000005592640944 <runtime.doInit+0x0000000000000064>  0x000000559373ecb6 
0x00000040005355f0:  0x0000005593384d60 <github.com/docker/cli/vendor/github.com/googleapis/gnostic/OpenAPIv2.init.1+0x0000000000000070>  0x0000024001d4fc28 
0x0000004000535600:  0x00000040000021a0  0x0000004000535688 
0x0000004000535610:  0x0000005592640950 <runtime.doInit+0x0000000000000070>  0x6300005593dd1cf8 
0x0000004000535620: <0x0000005593cc3580  0x6334ada4dd54d0c4 
0x0000004000535630:  0x0000005593dbc4f8  0x00000040003f3c68 
0x0000004000535640:  0x000000400035e090  0x0000005593cc3580 
0x0000004000535650:  0x00000040003f3b80  0x00000040005356a8 
0x0000004000535660:  0x0000005592640a18 <runtime.doInit+0x0000000000000138>  0x0000005593b60000 
0x0000004000535670:  0x000000400035e091  0x0000005593760d01 
0x0000004000535680:  0x0000000000000019  0x0000005593dbc4f8 
0x0000004000535690:  0x0000005594aed7e8  0x0000005594aed7e8 
0x00000040005356a0:  0x0000005594b1c580  0x00000040005357e8 
0x00000040005356b0:  0x0000005592640950 <runtime.doInit+0x0000000000000070>  0x0000005594aed780 
0x00000040005356c0:  0x00000040005356f8  0x0000000000000003 
0x00000040005356d0:  0x00000040004f4b60  0x0000005593db0e40 
0x00000040005356e0:  0x00000040004f4cb0  0x0000000000000000 
0x00000040005356f0:  0x00000040004f4b60  0x0000000000000002 
0x0000004000535700:  0x0000000000000002  0x0000000000000000 
0x0000004000535710:  0x0000000000000000  0x0000005593db0d50 
0x0000004000535720:  0x00000040004fe2c0  0x0000004000535768 
0x0000004000535730:  0x0000005592eedde4 <github.com/docker/cli/vendor/k8s.io/apimachinery/pkg/runtime.(*SchemeBuilder).AddToScheme-fm+0x0000000000000034>  0x00000040004f4b60 
0x0000004000535740:  0x00000040004b8400  0x0000000000000000 
0x0000004000535750:  0x0000000000000001  0x000000400038a630 
0x0000004000535760: >0x00000040004f4b60  0x000000400025f788 
0x0000004000535770:  0x000000559331a194 <github.com/docker/cli/vendor/github.com/docker/compose-on-kubernetes/api/client/clientset/scheme.AddToScheme+0x0000000000000064>  0x0000005593db43b0 
0x0000004000535780:  0x00000040003a3ef0  0x000000400025f7a8 
0x0000004000535790:  0x000000559331a110 <github.com/docker/cli/vendor/github.com/docker/compose-on-kubernetes/api/client/clientset/scheme.init.0+0x0000000000000050>  0x0000005593db4518 
0x00000040005357a0:  0x00000040004f4b60  0x000000400025f7e8 
0x00000040005357b0:  0x0000005592640a18 <runtime.doInit+0x0000000000000138>  0x0000004000389098 
0x00000040005357c0:  0x0000000000000000  0x0000000000000003 
0x00000040005357d0:  0x0000005594aea960  0x0000005594aea950 
0x00000040005357e0:  0x00000040003b1ac0  0x0000004000535928 
0x00000040005357f0:  0x0000005592640950 <runtime.doInit+0x0000000000000070>  0x0000005594af9640 
0x0000004000535800:  0x68000040000b5440  0x0000000000000002 
0x0000004000535810:  0x68a17a3226e6c12b  0x6c0000400025f858 
0x0000004000535820:  0x00000055929328d0 <github.com/docker/cli/vendor/github.com/gogo/protobuf/proto.RegisterType+0x0000000000000180>  0x0000000000000000 
0x0000004000535830:  0x00000040004d0db3  0x0000000000000001 
0x0000004000535840:  0x0000000000000010  0x0000000000000000 
0x0000004000535850:  0x0000000000000000  0x000000400025f918 
runtime.doInit(0x400025f788)
	/usr/lib/go-1.18/src/runtime/proc.go:6198 +0x64 fp=0x4000535760 sp=0x4000535620 pc=0x5592640944

goroutine 18 [chan receive]:
github.com/docker/cli/vendor/k8s.io/klog.(*loggingT).flushDaemon(0x0?)
	/build/docker.io-eV7TtD/docker.io-20.10.21/.gopath/src/github.com/docker/cli/vendor/k8s.io/klog/klog.go:1010 +0x60
created by github.com/docker/cli/vendor/k8s.io/klog.init.0
	/build/docker.io-eV7TtD/docker.io-20.10.21/.gopath/src/github.com/docker/cli/vendor/k8s.io/klog/klog.go:411 +0x148

ı use jetpack 4.6.4. and my system is ubuntu 18.04

and ı use this command

sudo systemctl status docker

and result is :

 docker.service - Docker Application Container Engine
   Loaded: loaded (/lib/systemd/system/docker.service; enabled; vendor preset: enabled)
   Active: active (running) since Mon 2023-11-27 14:36:53 +03; 7min ago
     Docs: https://docs.docker.com
 Main PID: 7883 (dockerd)
    Tasks: 9
   CGroup: /system.slice/docker.service
           └─7883 /usr/bin/dockerd -H fd:// --containerd=/run/containerd/containerd.sock

Kas 27 14:36:53 jetson dockerd[7883]: time="2023-11-27T14:36:53.455197268+03:00" level=warning msg="Your kernel does not 
Kas 27 14:36:53 jetson dockerd[7883]: time="2023-11-27T14:36:53.455614093+03:00" level=warning msg="Your kernel does not 
Kas 27 14:36:53 jetson dockerd[7883]: time="2023-11-27T14:36:53.455840032+03:00" level=warning msg="Your kernel does not 
Kas 27 14:36:53 jetson dockerd[7883]: time="2023-11-27T14:36:53.456437536+03:00" level=info msg="Loading containers: star
Kas 27 14:36:53 jetson dockerd[7883]: time="2023-11-27T14:36:53.668058982+03:00" level=info msg="Default bridge (docker0)
Kas 27 14:36:53 jetson dockerd[7883]: time="2023-11-27T14:36:53.759987727+03:00" level=info msg="Loading containers: done
Kas 27 14:36:53 jetson dockerd[7883]: time="2023-11-27T14:36:53.797579396+03:00" level=info msg="Docker daemon" commit="2
Kas 27 14:36:53 jetson dockerd[7883]: time="2023-11-27T14:36:53.798100961+03:00" level=info msg="Daemon has completed ini
Kas 27 14:36:53 jetson systemd[1]: Started Docker Application Container Engine.
Kas 27 14:36:53 jetson dockerd[7883]: time="2023-11-27T14:36:53.846014459+03:00" level=info msg="API listen on /var/run/d
lines 1-19/19 (END)

Hi,

Could you share the command that you launch the container with us as well?

Thanks.

Hi,
I use this command

./docker_dli_run.sh

I’m continue this course
https://courses.nvidia.com/courses/course-v1:DLI+S-RX-02+V2/course/

Hi,

Could you share more about your setting?
Are you using the SD card image?

The container is based on r32.7.1 BSP so it’s expected that your Nano is also flashed with the r32.7.1.

Thanks.

Hello
I am using the Jetson Nano development kit that I bought from Waveshare, and since it does not have enough memory, I copied it to my SD card and booted from there.
My jetson jetpack version is 4.6.4 but I am continue this course
https://courses.nvidia.com/courses/course-v1:DLI+S-RX-02+V2/course/
and
https://catalog.ngc.nvidia.com/orgs/nvidia/teams/dli/containers/dli-nano-ai
How can I find the Docker version according to my Jetpack version?

I use this command sudo apt-cache show nvidia-jetpack
and then result

Package: nvidia-jetpack
Version: 4.6.4-b39
Architecture: arm64
Maintainer: NVIDIA Corporation
Installed-Size: 194
Depends: nvidia-l4t-jetson-multimedia-api (&gt;&gt; 32.7-0), nvidia-l4t-jetson-multimedia-api (&lt;&lt; 32.8-0), nvidia-cuda (= 4.6.4-b39), nvidia-tensorrt (= 4.6.4-b39), nvidia-nsight-sys (= 4.6.4-b39), nvidia-cudnn8 (= 4.6.4-b39), nvidia-opencv (= 4.6.4-b39), nvidia-container (= 4.6.4-b39), nvidia-visionworks (= 4.6.4-b39), nvidia-vpi (= 4.6.4-b39)
Homepage: http://developer.nvidia.com/jetson
Priority: standard
Section: metapackages
Filename: pool/main/n/nvidia-jetpack/nvidia-jetpack_4.6.4-b39_arm64.deb
Size: 29388
SHA256: adf7a6660f73cdc4f95bc15c48d8588688e3afa5ee18bfd5b3a3caa3a458aa02
SHA1: 5abbe0df74f71579c1a0ee30ab7c2c236e1bcdbb
MD5sum: ec293a56d17f2b2793448d621811330d
Description: NVIDIA Jetpack Meta Package
Description-md5: ad1462289bdbc54909ae109d1d32c0a8

Package: nvidia-jetpack
Version: 4.6.3-b17
Architecture: arm64
Maintainer: NVIDIA Corporation
Installed-Size: 194
Depends: nvidia-l4t-jetson-multimedia-api (&gt;&gt; 32.7-0), nvidia-l4t-jetson-multimedia-api (&lt;&lt; 32.8-0), nvidia-cuda (= 4.6.3-b17), nvidia-tensorrt (= 4.6.3-b17), nvidia-nsight-sys (= 4.6.3-b17), nvidia-cudnn8 (= 4.6.3-b17), nvidia-opencv (= 4.6.3-b17), nvidia-container (= 4.6.3-b17), nvidia-vpi (= 4.6.3-b17)
Homepage: http://developer.nvidia.com/jetson
Priority: standard
Section: metapackages
Filename: pool/main/n/nvidia-jetpack/nvidia-jetpack_4.6.3-b17_arm64.deb
Size: 29368
SHA256: 694254a8667ebbf13852548bdd13a5b8ae61481ac059845b706398eefdcb9e01
SHA1: 67140fc8463ec61fd69352b225244b639c799edd
MD5sum: afa1382b6caded6b736d494fc481bab4
Description: NVIDIA Jetpack Meta Package
Description-md5: ad1462289bdbc54909ae109d1d32c0a8

Package: nvidia-jetpack
Version: 4.6.2-b5
Architecture: arm64
Maintainer: NVIDIA Corporation
Installed-Size: 194
Depends: nvidia-cuda (= 4.6.2-b5), nvidia-opencv (= 4.6.2-b5), nvidia-cudnn8 (= 4.6.2-b5), nvidia-tensorrt (= 4.6.2-b5), nvidia-visionworks (= 4.6.2-b5), nvidia-container (= 4.6.2-b5), nvidia-vpi (= 4.6.2-b5), nvidia-l4t-jetson-multimedia-api (&gt;&gt; 32.7-0), nvidia-l4t-jetson-multimedia-api (&lt;&lt; 32.8-0)
Homepage: http://developer.nvidia.com/jetson
Priority: standard
Section: metapackages
Filename: pool/main/n/nvidia-jetpack/nvidia-jetpack_4.6.2-b5_arm64.deb
Size: 29378
SHA256: 925f4abff97e6024d86cff3b9e132e7c7554d05fb83590487381b7e925d5b2bb
SHA1: e3ef727e87df5c331aece34508c110d57d744fe9
MD5sum: 7cb2e387af41bc8143ac7b6525af7794
Description: NVIDIA Jetpack Meta Package
Description-md5: ad1462289bdbc54909ae109d1d32c0a8

Package: nvidia-jetpack
Version: 4.6.1-b110
Architecture: arm64
Maintainer: NVIDIA Corporation
Installed-Size: 194
Depends: nvidia-cuda (= 4.6.1-b110), nvidia-opencv (= 4.6.1-b110), nvidia-cudnn8 (= 4.6.1-b110), nvidia-tensorrt (= 4.6.1-b110), nvidia-visionworks (= 4.6.1-b110), nvidia-container (= 4.6.1-b110), nvidia-vpi (= 4.6.1-b110), nvidia-l4t-jetson-multimedia-api (&gt;&gt; 32.7-0), nvidia-l4t-jetson-multimedia-api (&lt;&lt; 32.8-0)
Homepage: http://developer.nvidia.com/jetson
Priority: standard
Section: metapackages
Filename: pool/main/n/nvidia-jetpack/nvidia-jetpack_4.6.1-b110_arm64.deb
Size: 29366
SHA256: acfd9e75af780eab165361d61de4b4fe4974890864fe191060b402ac4c2f54d5
SHA1: a016568ac53705acc145a9f7e60505707bea259f
MD5sum: 79be976b184a8c885bd9169ea5b7fb7b
Description: NVIDIA Jetpack Meta Package
Description-md5: ad1462289bdbc54909ae109d1d32c0a8

hi my version is 32.7.4 how can ı download this container nvidia page ?

Hi,

Sorry, r32.7.x should be compatible.

The original error is related to Golang.
Do you install anything related to Golang?

Thanks

No I just flashed my jetson nano. And then I started this course.
https://courses.nvidia.com/courses/course-v1:DLI+S-RX-02+V2/course/
I haven’t done anything related to Go.
I found the cause of the problem. The version I use is 4.6.4 and as I mentioned in the photo, my L4T version is in the photo. There is a Docker container incompatibility.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.