Docker SDK Manager Flashing Jetson NX Unable to Detect Jetson Device

Hi! I am attempting to flash my Jetson NX with a docker SDK Manager running on a mac but the manager could not detect my jetson device:

I have tried all four options shown on the bottom left hand and followed its instructions to either power on/off the jetson, as well as have it plugged into the host computer via USB micro-b. What might be causing the device to be undetected?

Hi gg22,

What is the command line to run this docker? Did you use --privileged option to enable usb access in the container?
After you manually put Jetson to recovery mode, can you please run lsusb command in both host and in container respectively to paste output?

The command line I run with was:

$ docker run -it --privileged -v /dev/bus/usb:/dev/bus/usb/ --name JetPack_NX_Devkit sdkmanager --cli install --logintype devzone --product Jetson --targetos Linux --host --target JETSON_XAVIER_NX_TARGETS --version DP_5.0 --select 'Jetson OS' --deselect 'Jetson SDK Components' --flash all --license accept --staylogin true --datacollection enable --exitonfinish

I’m not sure if I specified the right privileged option.

Here is my MacOS lsusb output:

I’m unsure as to how to run lsusb in the container, could you advise me as to how?

Hi gg22,

Probably you could run lsusb command with the same docker image, but in a different container.
sudo docker run -it --privileged -v /dev/bus/usb:/dev/bus/usb/ --entrypoint /bin/bash <sdkmanager_image_id>

Thanks for your help.

I was able to enter the bash and run lsusb, but the output was nothing, which is a problem. Any idea as to why this may be?

However, although lsusb outputs nothing, I was able to locate directory /dev/bus/usb/002/001 and /dev/bus/usb/000/000 inside the docker container. But, they were both empty. Not sure if this is helpful.

There is no update from you for a period, assuming this is not an issue any more.
Hence we are closing this topic. If need further support, please open a new one.
Thanks

Hi gg22,

In the document, there are additional two arguments, -v /dev:/dev -v /media/$USER:/media/nvidia:slave, can you please try if they are useful to solve the issue?

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.