Docker SDK manager "Sorry, user may not run sudo on %HOSTNAME"

I am facing a problem using the sdk manager under linux with the docker image for 18.04 provided in
I am using 18.04 container since jetpack 4.6.2 was only available on that OS. my current distribution on the host is 20.04.
The docker image is imported ok and so I run:
docker run -it --privileged -v /media/$USER/sdk2/home_nvidia:/home/nvidia -v /media/$USER/sdk2/tmp:/tmp -v /media/$USER/sdk2/home_nvidia/downloads:/media/$USER/sdk2/home_nvidia/downloads --rm --name JetPack_NX_Devkit --network host sdkmanager --cli install --logintype devzone --product Jetson --version 4.6.2 --targetos Linux --host --target JETSON_XAVIER_NX_TARGETS --license accept --staylogin true --datacollection enable --downloadfolder /media/$USER/sdk2/home_nvidia/downloads

I am using an SD card as external storage to host downloads/images since I dont have much space on the other partitions.

I arrive to this screen when sdkmanager asks for password:

In the second and third attempts to ask for password the prompt in the window above was: “User does not have administrative rights”
But then it asks the password again and the third time, it exits with this message:

Sorry, user may not run sudo on $HOSTNAME

I sincerely don’t know how to make this to work. Can someone give me some hint?

Even trying with -u nvidia and password nvidia (as the user guide states) but same behavior.

I see that in this link:

The prompt for password should mention the user; I notice that mine does not have a user. Should it be the user I am using on the host computer? If that is the case, it means that sdkmanager somehow should guess it by the parameters I am giving to it. Please let me know how to fix it.


same error message here

my docker run command is

docker run -it \
    --name=jetpack-sdk \
    --rm=true \
    --net=host \
    --ipc host\
    --privileged \
    --volume="/dev/bus/usb:/dev/bus/usb" \
    --user "$(id -u):$(id -g)" \
    --env="DISPLAY=$DISPLAY" \
    --volume="/tmp/.X11-unix:/tmp/.X11-unix:rw" \
    jetpack-sdk /bin/bash

I also can enter the the CLI menu but after entering sudo passwrod,
it is kicked out the install interface.

hi ggavilanes,
do you access into ubuntu 18.04 by root or user?
I use user at the beginning but encounter the same problem like you.
I change the docker run parameter to use root to access into container
and it works. you can try this method.

I tried that too, but the problem persisted. The strange thing is that I downgraded to sdk container version 1.8 and it worked again.