Documentation Rabbit Holes - Docker, LXC, Dead Ends

Greetings,

I am super frustrated with NVIDIA right now. Let me explain.

  1. While I was in the USAF, I wanted to develop my robots with the Isaac SDK. The main road block was that I could not buy a high end PC with the NVIDIA GPU installed due to policy.

Now I am working for a private company and was able to purchase a computer with an RTX 3060 installed but they shipped it in 20.04 and I need 18.04 to use the SDK!

Guess what? I can’t install 18.04 because of how new the graphics card is. Of course, I understand we are to be left in the dark about the hopes of using 20.04 someday due to Kernel compatibilities and such. But this is absolutely frustrating!

  1. I have been reading these guides over and over. I found a link where a developer was able to run a “ping” tutorial through LXC. I succeed with that. Later I find something about running in Docker. So I tried and example as shown in the NVIDIA documentation. It Does Not Work!

I feel like the combination of not understanding enough about linux, docker, LXC and the endless rabbit holes make using this SDK a mountain of a task when it is being sold as a “super easy” way to develop cutting edge robotics.

Cheers,

Coach

2 Likes

Could you elaborate more on what the issues were with using your RTX3060 with Ubuntu 18.04? That shouldn’t be a problem, though. I run with Ubuntu 20.04 and use a Docker container to build under 18.04 (Focal and Bionic have the same kernel). Isaac SDK supports only Bionic (18.04) which makes it easy to deploy to Jetsons running JetPack 4.x (also based on Bionic). If you have specific problems you could describe, we could help work through them as best we can.

1 Like

So I purchased a computer from Digital Storm:

Intel Core i9-11900K
MB: Asus Prime Z590-P
64GB RAM
GeForce RTX 3060 12GB
and a lot of other things like hard drives etc

I created a USB drive with the 18.04 installer and when I start the PC up with it installed in any one of the USB ports, I select the boot menu. At first, I didn’t know about editing the grub and the screen went black which triggered a support ticket. Their Linux tech advised me to edit the grub by adding various permutations of the following:

nomodeset
nouveau.modeset=0
rd.driver.blacklist=nouveau
modprobe.blacklist=nouveau

to the end of the linux line. I even tried removing quiet splash. All of this to no avail. During my own Google search I saw somewhere that Linux 18.04 might not support it because its too new of a GPU. This morning though, after reading your response, I removed the GPU and plugged the HDMI into the onboard connection and did the same steps mentioned above. Same symptoms! So now I don’t even know what I am doing wrong.

I also have a Lenovo laptop with a NVIDIA Quadro installed so I tried to install 18.04 on it. I ended up not being able to get updates or even get the Ubuntu to recognize any of the networking devices to connect to the internet and download drivers much less anything from NVIDIA. So that idea was shot also.

The first thing I tried was using LXC. Here’s a write up I found. During the setup, it seemed to have a lot of errors (I saw lines of red). But it did successfully run the ping example though.

Then there’s this NVIDIA example. I followed everything completely.

Installed Docker using this guide

And for some reason when I got the end of the NVIDIA guide of using Docker to complete step #4 bazel build ... the output is complaining about the missing bazel rc file. And no matter what directory of /isaac I am in I can’t get it to run. It also appears as though I am signed in as root and not a user inside the docker. Like I said, I not a guru in docker because I have never needed it until now. However, I feel like if I could get 18.04 to install properly, most of these work arounds won’t be a limiting factor.

Cheers,

Coach

I figured it out mostly.

The Ubuntu issues was with the installer not the hardware.

Cheers,