Does Latest Cuda CUDA Toolkit 11.5.1 0r CUDA Toolkit 11.4.3 support Glibc-2.34?

Does Latest Cuda CUDA Toolkit 11.5.1 0r CUDA Toolkit 11.4.3 support Glibc-2.34 and gcc 11.2?

no where in documentation mentioned these details. previous releases definitely does not support Glibc-2.34.

as you may aware that ubuntu/fedora/others are moving to Glibc-2.34

Regards.

Should be 11.5.1

The issue with cuda 11.5.1 that requires Linux driver >=495.29.05 and Nvidia Driver 495.xx does not support legacy Linux graphics drivers. so cuda 11.5.xx has less graphics card support.

do you know if cuda 11.4.3 supports Glibc-2.34 and gcc 11.2?

No. Both toolkit’s Linux Installation Guides list lower required versions, the closest being Fedora 34 with GCC 11 and Glibc 2.33.

This does not mean the toolkit won’t function with 2.34, just that Nvidia has not qualified it.

The 11.5.1 Release notes state that driver >=450.80.02 is the minimum required:

https://docs.nvidia.com/cuda/cuda-toolkit-release-notes/index.html#cuda-major-component-versions

Cuda 11.5 & 11.4 confirmed that does not work on glibc 2.34. I tested myself. but I don’t know about 11.5.1 & 11.4.3.

as per document,
Release Notes :: CUDA Toolkit Documentation (nvidia.com)

clearly stating 11.5.1 requires Linux driver >=495.29.05. please feel free to test it and let us know your feedback.

Table 2 in the document:

"Minimum Required Driver Version for CUDA Minor Version Compatibility*

CUDA 11.5.x >=450.80.02"