Doesn't really well work shadow age of nvDCF tracker

• Hardware Platform (Jetson / GPU):jetson
• DeepStream Version:5.0 ga
• JetPack Version (valid for Jetson only): 4.4
• TensorRT Version:7.1

In the tracker_config.yml of nvDCF tracker, there is a maxShadowTrackingAge=30, an this is Max length of shadow tracking (the shadow tracking age is incremented when (1) there’s detector input yet no match or (2) tracker confidence is lower than minTrackerConfidence). This option is length history of object when this object is not detected until reach to maxShadowTrackingAge frame, But even I set this option to 1000, but when a object is not detected for some frame, then the ID of that object is changed and increased, why? I want to when a object is not detected for 100 frame then I assign the same ID for that object after 101 frame. How I can to solve this problem?

The tracker result is not decided by single parameter.


1 Like

You can also refer to Track id not continuous

1 Like