Double Precision box is missing for GTX Titan Black


I’m a student. I purchased a Titan Black recently. I know it’s an old card but it’s still the best budget fp64 card out there.

I’m running the latest ubuntu. When I launch nvidia server x (nvidia gui control panel for linux) the checkbox for enabling double precision is simply not there. I tried multiple drivers and even a full os reinstall but it just wont work. The card is detected and works fine (other than the missing checkbox).

I don’t get it, is there something I’m missing? With matlab the card works fine, but it has 200 gflops only.

Does anyone know what im supposed to do? Any help would be greatly appreciated.

It’s been a while, but IIRC, the option is only present in Windows drivers and persists on Linux.