Downgrade from Ubuntu 20.04 to 18.04

I updated my Xavier to Ubuntu 20.04 and now want to downgrade back to 18.04. No matter what I try, my Xavier always shows 20.04. I reimaged my hosted machine back to 18.04 and installed the latest sdk manager. I’ve tried both automatic and manual force recovery.

Attached are the latest logs which used the force recovery. I’d appreciate some help!

Thanks! (309.0 KB)

Hi hoginsbu,

The JetPack-5.0.1 DP, the image version is ubuntu 20.04.
If you want downgrade to ubuntu 18.04, please install JetPack-4.6.2 or JetPack-4.6.1.
No matter host machine is 18.04 or 20.04, you all can use SDK Manager to install JetPack on Xavier.

As soon as I read your reply, I started shaking my head in embarrassment. :) That makes perfect sense! I reimaged and it worked fine. Thanks for your help!

Jetpack 4.6.x or any older version than 5 are not selectable in sdkmanager, any solutions for that? i also want to downgrade to 4.6.1

1 Like

Hi s.alers,

Please run below command to install old JetPack version:
$ sdkmanager --archivedversions

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.