Download issues - JetPack 3.2

I’m getting 404 errors downloading some packages using the JetPack 3.2 URLs. For example:
http://developer.download.nvidia.com/devzone/devcenter/mobile/jetpack_l4t/3.2GA/m892ki/JetPackL4T_32_b196/cuda-repo-l4t-9-0-local_9.0.252-1_arm64.deb

Have those URLs been removed on purpose?

In my case it opens.
You should authenticate before downloading.

I’ve authenticated and also cannot access this. Originally this would have been referred to via the JetPack3.2 file “repository.json”. I have not re-run JetPack, but this particular file was intended to be updated each run of JetPack…perhaps running JetPack again would change this (just speculating that there might be an change to repository.json now that JetPack3.2.1 is out…if reusing a directory for JetPack this might cause something to not be refreshed).

In my case it downloads the file just fine:
cuda-repo-l4t-9-0-local_9.0.252-1_arm64.deb 604.9 MB (604852294 bytes)

For me:

wget http://developer.download.nvidia.com/devzone/devcenter/mobile/jetpack_l4t/3.2GA/m892ki/JetPackL4T_32_b196/cuda-repo-l4t-9-0-local_9.0.252-1_arm64.deb
--2018-06-23 11:13:03--  http://developer.download.nvidia.com/devzone/devcenter/mobile/jetpack_l4t/3.2GA/m892ki/JetPackL4T_32_b196/cuda-repo-l4t-9-0-local_9.0.252-1_arm64.deb
Resolving developer.download.nvidia.com (developer.download.nvidia.com)... 2606:2800:21f:3aa:dcf:37b:1ed6:1fb, 192.229.211.70
Connecting to developer.download.nvidia.com (developer.download.nvidia.com)|2606:2800:21f:3aa:dcf:37b:1ed6:1fb|:80... connected.
HTTP request sent, awaiting response... 404 Not Found
2018-06-23 11:13:03 ERROR 404: Not Found.

I poked around with a browser as well after logging in and got the same result. Success may indicate something cached the content, or else the server works differently depending on your address.

wget

wget http://developer.download.nvidia.com/devzone/devcenter/mobile/jetpack_l4t/3.2GA/m892ki/JetPackL4T_32_b196/cuda-repo-l4t-9-0-local_9.0.252-1_arm64.deb
--2018-06-24 06:32:57--  http://wget/
Resolving wget (wget)... failed: Name or service not known.
wget: unable to resolve host address ‘wget’
--2018-06-24 06:32:57--  http://developer.download.nvidia.com/devzone/devcenter/mobile/jetpack_l4t/3.2GA/m892ki/JetPackL4T_32_b196/cuda-repo-l4t-9-0-local_9.0.252-1_arm64.deb
Resolving developer.download.nvidia.com (developer.download.nvidia.com)... 2606:2800:233:ef6:15dd:1ece:1d50:1e1, 192.229.221.58
Connecting to developer.download.nvidia.com (developer.download.nvidia.com)|2606:2800:233:ef6:15dd:1ece:1d50:1e1|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 604852294 (577M) [application/x-deb]
Saving to: ‘cuda-repo-l4t-9-0-local_9.0.252-1_arm64.deb’

       cuda-repo-l4   0%[                    ]  85.47K  80.8KB/s               ^C

It appears to use slightly different ip address. May be that is because I am in a different region?
I am just wondering if it will download the file if you add to the hosts the file the ip from the quote above for the developer.download.nvidia.com name

Yes, different regions probably aim at different servers; however, this might be DNS instead of JetPack…I don’t know. The reply to “host developer.download.nvidia.com” depends on your DNS server. On the other hand, what repository.json has in it for which to apply the “host” command to might differ depending on where you are…dont’ know.

I have not run JetPack3.2 recently and so my repository.json may be out of date. Re-running JetPack could possibly fix the issue…I don’t know. I’ll speculate that because JetPack3.2.1 came out some of the URLs may have moved. Or it could just be a server misconfiguration.

An experiment I did was to re-run the “_installer/Launcher” (it wasn’t an actual flash…I just ran JetPack-L4T-3.2-linux-x64_b196.run from a clean directory to the point it shows packages…this is when repository.json is generated). Something unexpected happened…repository.json “version” regressed from “3.2” to “3.1”. The 3.2 JetPack started downloading the wrong repo. My saved version from a flash back before JetPack3.2.1 came out shows version “3.2”. The “compDirectory” disappeared.

So I tried running again, and the GUI specifically says “JetPack L4T 3.2 Installer”. I double checked TX2 is checked. I went on to complete the “accept EULA” step and let it actually download all files. Once again, the “repository.json” entry for “version” fails with version “3.1” despite being “JetPack-L4T-3.2-linux-x64_b196.run”. This may not actually matter since individual “download” URLs have their own content and if those are right download will still be right. Even so, this is a bug in repository.json.

Looking at individual downloads I see the TX1 download of cuda-repo-l4t set to version 8 and the TX2 download of cuda-repo-l4t completely missing. Which confirms there is a configuration error in JetPack3.2 repository.json probably caused by something in the deprecation process as JetPack3.2.1 came out. Perhaps there are different servers with different vesions of repository.json not in sync.

What I’ll suggest is download JetPack3.2.1 instead, and if you need a URL instead of installing from JetPack, then run JetPack3.2.1 until you get repository.json and stop there, then extract the address again. The newest release should have the correct URL.

Ok, we will try to download JetPack3.2.1 and see if we can find the new URL in repository.json

Thanks,
-m

For anyone interested, cuda and cudnn for jetpack 3.2.1 are available here:

https://developer.download.nvidia.com/devzone/devcenter/mobile/jetpack_l4t/3.2.1/m8u2ki/JetPackL4T_321_b23/cuda-repo-l4t-9-0-local_9.0.252-1_arm64.deb

https://developer.download.nvidia.com/devzone/devcenter/mobile/jetpack_l4t/3.2.1/m8u2ki/JetPackL4T_321_b23/libcudnn7_7.0.5.15-1+cuda9.0_arm64.deb

Hi m-d

do you also have the direct links for the dev package related to libcudnn7_7.0.5.15-1+cuda9.0_arm64.deb ?

TIA

I answer myself :)

https://developer.download.nvidia.com/devzone/devcenter/mobile/jetpack_l4t/3.2.1/m8u2ki/JetPackL4T_321_b23/libcudnn7-dev_7.0.5.15-1+cuda9.0_arm64.deb

and bonus :

https://developer.download.nvidia.com/devzone/devcenter/mobile/jetpack_l4t/3.2.1/m8u2ki/JetPackL4T_321_b23/libcudnn7-doc_7.0.5.15-1+cuda9.0_arm64.deb