Downloading ecam130 software to work with AGX Xavier

Hi there, I recently got ahold of the ecam130_CUXVR and am trying to setup the software that is detailed in the Getting Started PDF. I am new to all of this technology and am having trouble running commands in terminal. In the screenshot attached, I am able to see the device listed when I run “lsusb”, however I get into trouble past this step. It says to run the following commands to extract the release package for
obtaining the quick start package.
tar xaf e-
CAM130_CUXVR_JETSON_AGX_XAVIER_<L4T_version><release
date><release_version>.tar.gz
cd e-
CAM130_CUXVR_JETSON_AGX_XAVIER
<L4T_version><release
date>_<release_version>/Quick_Start/

My first problem is finding the correct versions of the product, but after running this command multiple times with different variations, I typically get “No such file or directory” as the output.

$ tar xaf e- CAM130_CUXVR_JETSON_AGX_XAVIER_L4T32.1_4.26.2019_1.7.2.tar.gz

output:
tar: e-: Cannot open: No such file or directory
tar: Error is not recoverable: exiting now

I know I am doing something wrong here, but I cannot figure out what exactly. Any help would be greatly appreciated, thanks!

Hi charlotte.chang2001,

Avoid the empty space between the e- and CAM130_CUXVR_JETSON_AGX_XAVIER_L4T32.1_4.26.2019_1.7.2.tar.gz while running the below command,

$ tar xaf e-CAM130_CUXVR_JETSON_AGX_XAVIER_L4T32.1_4.26.2019_1.7.2.tar.gz

Also confirm the availability of e-CAM130_CUXVR_JETSON_AGX_XAVIER_L4T32.1_4.26.2019_1.7.2.tar.gz release package in the current directory by running the ls command in the same terminal and share the results with us,

$ ls

Can you confirm whether you downloaded the e-CAM130_CUXVR release package from e-con developer website or from the SD Card shared by e-con ?

We highly recommend to write up a mail to techsupport@e-consystems.com, so they will assist you in a faster and better way.

Hi Radhika!

First off, thank you for pointing out my mistake! And I tried the command without the space between the e- and CAM130_CUXVR_JETSON_AGX_XAVIER_L4T32.1_4.26.2019_1.7.2.tar.gz, this is what I get:

Here is what I type into terminal:
$ tar xaf e-CAM130_CUXVR_JETSON_AGX_XAVIER_L4T32.1_4.26.2019_1.7.2.tar.gz

Output:
tar: e-CAM130_CUXVR_JETSON_AGX_XAVIER_L4T32.1_4.26.2019_1.7.2.tar.gz: Cannot open: No such file or directory
tar: Error is not recoverable: exiting now

And I downloaded the release package from the econ developer website.

I attached a screenshot of what I see when I run the ls command below.

Thank you in advance for your help! I will try writing techsupport@e-consystems.com.

Hi charlotte.chang2001,

My apologies for the delayed response.

With the ls and tar command results shared by you , it was clear that, e-CAM130_CUXVR_JETSON_AGX_XAVIER_L4T32.1_4.26.2019_1.7.2.tar.gz release package is not available in the current path from where you’re trying to execute the commands.

And the release package name mentioned in the tar command is also not the formal nomenclature followed by e-con.

Kindly confirm the release package name that you have downloaded from e-con website.

I apologize I forgot to respond! I thought I downloaded it correctly - I went to the website you attached (https://www.e-consystems.com/nvidia-jetson-camera.asp) and then clicked on “Xavier cameras” then clicked on “e-CAM130_CUXVR” and downloaded the documents on the right hand side of the page “e-CAM130_CUXVR Documents” (https://www.e-consystems.com/doc_fourcam_jetson_xavier_Camera.asp) and am currently looking at page 14 of the Getting Started Manual where I see the tar command in step number 3 of the Software Quick Setup.