Dp output did not specify bpp

Is this a hardware or software error?
How to fix it?

opt@opt-desktop:~$ dmesg | grep 15220000.nvdisplay
[ 0.451016] iommu: Adding device 15220000.nvdisplay to group 33
[ 1.269206] tegradc 15220000.nvdisplay: disp1 connected to head2->/host1x/sor
[ 1.269339] tegradc 15220000.nvdisplay: DT parsed successfully
[ 1.269364] tegradc 15220000.nvdisplay: Display dc.ffffff800ba20000 registered with id=1
[ 1.269667] tegradc 15220000.nvdisplay: vblank syncpt # 11 for dc 2
[ 1.269673] tegradc 15220000.nvdisplay: vpulse3 syncpt # 12 for dc 2
[ 1.281516] tegradc 15220000.nvdisplay: probed
[ 1.281807] tegradc 15220000.nvdisplay: fb registered
[ 1.302243] tegradc 15220000.nvdisplay: tegra_dp_get_bpp: vmode=0x10600000 did not specify bpp
[ 1.318490] tegradc 15220000.nvdisplay: dp: aux write defer (0x10020000) – 6
[ 1.323160] tegradc 15220000.nvdisplay: dp: aux read defer (0x10020000) – 6
[ 1.326393] tegradc 15220000.nvdisplay: dp: aux read defer (0x10020000) – 6
[ 1.454543] tegradc 15220000.nvdisplay: tegra_dp_get_bpp: vmode=0x10600000 did not specify bpp
[ 3.549597] tegradc 15220000.nvdisplay: tegra_dp_get_bpp: vmode=0x10600000 did not specify bpp
[ 3.550115] tegradc 15220000.nvdisplay: tegra_dp_get_bpp: vmode=0x10000000 did not specify bpp
[ 3.550577] tegradc 15220000.nvdisplay: tegra_dp_get_bpp: vmode=0x10000000 did not specify bpp
[ 3.551035] tegradc 15220000.nvdisplay: tegra_dp_get_bpp: vmode=0x10000000 did not specify bpp
[ 3.551493] tegradc 15220000.nvdisplay: tegra_dp_get_bpp: vmode=0x10000000 did not specify bpp
[ 3.551952] tegradc 15220000.nvdisplay: tegra_dp_get_bpp: vmode=0x10000000 did not specify bpp
[ 3.552410] tegradc 15220000.nvdisplay: tegra_dp_get_bpp: vmode=0x10000000 did not specify bpp
[ 3.552868] tegradc 15220000.nvdisplay: tegra_dp_get_bpp: vmode=0x10000000 did not specify bpp
[ 3.553326] tegradc 15220000.nvdisplay: tegra_dp_get_bpp: vmode=0x10000000 did not specify bpp
[ 3.553789] tegradc 15220000.nvdisplay: tegra_dp_get_bpp: vmode=0x10000000 did not specify bpp
[ 3.554251] tegradc 1

We can see that even in working case, so it is probably not an fatal issue.

1 Like

I switched the system monitor expansion and mirror mode and then recovered, dp
and hdmi worked